Burp Suite User Forum

Login to post

Lab not found

Hello, when I open any of the web security labs, it shows me that the resource could not be found. I tried several labs and it gives me the same message every time.

Last updated: Aug 11, 2020 07:16PM UTC | 0 Agent replies | 0 Community replies | Bug Reports

Can't install / launch burpsuite pro on latest Kali

Hi. I am trying to install burpsuite pro 2020.8 on the latest Kali release. I've tried using openjdk-11 as well as openjdk-8 with both results. after running burpsuite_pro_linux_v2020_8.sh I can see a new window hoping which...

Last updated: Aug 11, 2020 10:29AM UTC | 1 Agent replies | 0 Community replies | Bug Reports

v2020.7 Embedded Browser Doesn't Launch on Parrot

Hello, I just wanted to report that the embedded browser in 2020.7 does not launch with a default Parrot OS (https://parrotlinux.org/) configuration. Attempts to launch it return "net.portswigger.devtools.client.a: Refusing...

Last updated: Aug 11, 2020 03:11AM UTC | 4 Agent replies | 7 Community replies | Bug Reports

Ldd error after upgrading to 2020.7

Hello guys, after the update 2020.7 my Embedded browser check failed. "Aborting checks due to errors. Could not determine dependencies as an error occurred executing ldd" No more details. Linux XXXXXX...

Last updated: Aug 07, 2020 07:28AM UTC | 6 Agent replies | 5 Community replies | Bug Reports

iOS 13 + Burp SSL Certs Not Able to be Fully Trusted

I've followed the appropriate steps to fully trust the burp cert, but as of iOS 13 this does not work and HTTPS requests fail. Looking at iOS 13 release notes, I found this: https://support.apple.com/en-us/HT210176 -- I...

Last updated: Aug 05, 2020 01:49PM UTC | 31 Agent replies | 59 Community replies | Bug Reports

Burp certificate not working with Burp 1.7

Burp certificate not working with Burp 1.7 butis working with latest versions.

Last updated: Aug 04, 2020 11:29AM UTC | 2 Agent replies | 2 Community replies | Bug Reports

Embedded browser initialization failed

Hi I am having an issue with the Response/Render feature of the embedded browser. When I click on "Render" in the "Response" tab I receive the following message "Embedded browser initialization failed" I also ran...

Last updated: Aug 04, 2020 11:02AM UTC | 21 Agent replies | 39 Community replies | Bug Reports

OPEN API PARSER NOT Working with OpenAPI Specification version 3.0.

OPEN API PARSER NOT Working with OpenAPI Specification version 3.0. When trying to parse/load the YAML or JSON from the Swagger Pets store example, The parser responds at the bottom with 'The OpenAPI specification...

Last updated: Aug 04, 2020 10:57AM UTC | 1 Agent replies | 0 Community replies | Bug Reports

Sorting arrows not showing in Dark Theme

Hello, I've started to use the Darcula/Dark Theme, and I've noticed that it looks like sorting arrows in tools such as Intruder are not being displayed properly (e.g, when double clicking "Length" on an Intruder attack...

Last updated: Aug 03, 2020 10:10AM UTC | 1 Agent replies | 0 Community replies | Bug Reports

either live passive crawl or live audit keep session active

During a recent web app test I found a bug in the web app where I could replay the request after logging out. However, further testing and working with the developers where they could watch the backend session id's we found...

Last updated: Aug 03, 2020 09:20AM UTC | 1 Agent replies | 0 Community replies | Bug Reports

Having issues opening Burp - started today

Hello, I try to open Burp Professional and the logo comes up then disappears. Nothing happens. I have tried to re-install, even the older versions and the same issue is happening. Please advise.

Last updated: Aug 03, 2020 07:53AM UTC | 1 Agent replies | 0 Community replies | Bug Reports

Burp repeter - cant build from scratch

When I build a Request from scratch I got timeout in response meanwhile If I take the request from proxy sent to repeater I got 200 OK. Example Request: GET /success.txt HTTP/1.1 Host:...

Last updated: Aug 03, 2020 07:24AM UTC | 1 Agent replies | 0 Community replies | Bug Reports

java.net.SocketException: Connection reset

I am able to reach the site I am testing over HTTPS via browser directly, but when I use Burp to connect I see two errors in the Alerts tab: java.net.SocketException: Connection reset Connection reset This happens...

Last updated: Aug 03, 2020 06:11AM UTC | 5 Agent replies | 5 Community replies | Bug Reports

Installing Burp Enterprise in PostgreSql

Hi, There is any limitation to use Burp Enterprise and Azure Database for PostgreSql? I ask because I am trying to install Burp Enterprise (in Linux 64 bit) using Azure Database for Postgre and the Burp installation...

Last updated: Jul 30, 2020 08:59AM UTC | 2 Agent replies | 1 Community replies | Bug Reports

Lab: Stored XSS into anchor href attribute with double quotes HTML-encoded

Hi! The lab does not register the fact that XSS has executed and means I cannot complete the challenge. javascript:alert(document.domain) successfully pops up however the website does not register this fact, which...

Last updated: Jul 29, 2020 11:49PM UTC | 0 Agent replies | 1 Community replies | Bug Reports

license key

i reinstalled burp enterprise and now its not accepting same license key file.

Last updated: Jul 29, 2020 12:14PM UTC | 1 Agent replies | 0 Community replies | Bug Reports

Burp Not Capturing All HTTP Traffic

Hi, I try to capture HTTP traffic from a desktop app. I set Burp as a proxy on 8081 port in different client. But Burp not capturing all traffics. I am watching 8081 port with tcpdump, i am seeing the requests but Burp can...

Last updated: Jul 27, 2020 02:39PM UTC | 1 Agent replies | 0 Community replies | Bug Reports

Session Handling Rules doesn't work

Hi, I founded bug with session handling rules. I wrote custom rules to rewrite cookies if session is not valid. But when I restart my burp app, this rules doesn't work. To fix this problem I would go to my rules and open...

Last updated: Jul 27, 2020 11:48AM UTC | 4 Agent replies | 2 Community replies | Bug Reports

ASP ViewState does not show up

I have an issue with the ViewState Tab not showing up in the Request/Response view I can see the hidden form elements and on a POST request I can see the Parameters being sent, but the Tab is not showing up. Here is a...

Last updated: Jul 27, 2020 08:35AM UTC | 2 Agent replies | 1 Community replies | Bug Reports

Error on scanning with Burp suite Professional v2020.6

Hi, after upgrading to v2020.6 I see the following issues: by selecting to scan one website ( default options, right click on the URL scan, 'Crawl and audit' ) the following will happen in most of the cases: 1. Scan...

Last updated: Jul 27, 2020 07:44AM UTC | 3 Agent replies | 2 Community replies | Bug Reports

Page 1 of 55

Burp Suite Support Center

Your source for help and advice on all things Burp-related.

Burp Suite Support Center image