Burp Suite User Forum

Login to post

Websockets not working with burp

alvli | Last updated: Jan 01, 2020 07:30PM UTC

my browser unable to connect *any* websocket while working with burp I also tried changing my browser. I'm getting this error on firefox (similar messages in other browsers): "Firefox can’t establish a connection to the server at wss://" reinstalled burp tried diffrent browsers switched to burp community cleaned all files about burp nothing worked let me know if any further information required to help me to fix this issue Thanks

Hannah, PortSwigger Agent | Last updated: Jan 02, 2020 10:29AM UTC

Hi. For Firefox, would you be able to try unchecking the "Use this proxy server for all protocols" and then leave the SOCKS Host field empty within the Proxy settings?

Ben, PortSwigger Agent | Last updated: Jan 02, 2020 10:31AM UTC

Hi Ringo, This behavior was only introduced in Firefox, Version 71 (prior to that version the suggested workaround was not required) so we are currently monitoring future Firefox releases to see if this issue persists. If it does then we will look to update our documentation accordingly. Please let us know if you require any further information.

Burp User | Last updated: Jan 02, 2020 05:15PM UTC

Wow it's worked thank you :).

Burp User | Last updated: Jan 05, 2020 02:59AM UTC

Please update your directions to reflect this answer as I also struggled with this. https://support.portswigger.net/customer/portal/articles/1783066-configuring-firefox-to-work-with-burp

Burp User | Last updated: Jan 08, 2020 02:46PM UTC

It seems that this could be related to this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1517782 They recently switched websockets to HTTP/2 and this won't work if you try to use a what so ever proxy. Solution would be to downgrade to firefox 64, probz to the person that post the download link to this version.

Ben, PortSwigger Agent | Last updated: Jan 08, 2020 02:48PM UTC

Hi, It is related to the following: https://bugzilla.mozilla.org/show_bug.cgi?id=1601871 The suggested workaround provided by Hannah in this thread will work for Firefox, Version 71 so there is no need to downgrade.

vit | Last updated: Apr 17, 2020 10:45PM UTC

Hi, I am using current fresh version of Firefox v75.0(64bit) with Burp Community Edition 1.7.36 and 2020.2.1 Indeed, both versions of Burp does not work with websockets. I've tried in several sites. But had no luck. What I see from browser console is "Firefox can’t establish a connection to the server at wss://***/ws. ***.js:xxx:xxxx" In FF there is no longer the option like "Use this proxy server for all protocols" in proxy settings. Instead there is an option "also use this proxy for FTP and HTTPS". I've tried to uncheck "Strip-Sec-Websocket Extensions headers in incoming requests" but it did not help. The browser is still no capable to open websocket connection even if i disable websocket iterceptor in Burp by unchecking both options "Intercept client-to-server and server-client messages" the websocket connection became alive.

vit | Last updated: Apr 18, 2020 11:29AM UTC

I've just figured out a cause of the problem. No need to configure proxy for "Socks host" in browser settings. Just leave it unspecified and websockets will proxy traffic through Burp.

You need to Log in to post a reply. Or register here, for free.