Burp community forum

Websocket disconnect when "Send A Message" to it.

Hassan | Last updated: Jul 25, 2019 02:46PM UTC

Hello support, in the last version of burp I see that it is possible to reply websocket with repeater tab. but my problem is that when the websocket connection has been connected but after put a command message it disconnect fast. Also when intercepting the website with burp I can not to login to that because of that problem. I think there is problem when "Send A Message" to websocket. I tested all other tools like ZAP and they connects easily to the game when intercepting, but with burp it couldn't.

Liam, PortSwigger Agent | Last updated: Jul 26, 2019 12:41PM UTC

Could you update to the latest version (v2.1.02) and let us know if the problem persists. - http://releases.portswigger.net/2019/07/professional-community-edition-2102.html

Burp User | Last updated: Jul 31, 2019 07:08PM UTC

Hi, I installed the the latest version (v2.1.02) , but the problem still exists. burp WebSocket UI is weak still, and can not connect to some websites when intercepting a website with websocket the connection to website disconnected. In fact it connects to Websocket but after input the right message it disconnect.

Liam, PortSwigger Agent | Last updated: Aug 05, 2019 09:36AM UTC

Is the site publicly accessible? If not, could you provide a video demonstrating the issue? You can send any relevant information to support@portswigger.net.

You need to Log in to post a reply. Or register here, for free.