Burp Suite User Forum

Login to post

v2020.7 Embedded Browser Doesn't Launch on Parrot

Ramces | Last updated: Jul 17, 2020 06:09PM UTC

Hello, I just wanted to report that the embedded browser in 2020.7 does not launch with a default Parrot OS (https://parrotlinux.org/) configuration. Attempts to launch it return "net.portswigger.devtools.client.a: Refusing to start browser as your current configuration does not support running without sandbox."

Ibrahim | Last updated: Jul 18, 2020 05:20PM UTC

Same issue with Kali 2020.2a

Ben, PortSwigger Agent | Last updated: Jul 20, 2020 10:45AM UTC

Hi Ramces, Firstly, can you confirm whether you are using the root user or a non-root user?

Ramces | Last updated: Jul 20, 2020 06:50PM UTC

Hi Ben, I was running as a non-root user but hadn't noticed the setting to enable the embedded browser is in Project options; I had checked user User options instead. The browser launches with non-root on Parrot.

Ben, PortSwigger Agent | Last updated: Jul 21, 2020 08:11AM UTC

Hi Ramces, Thank you for confirming that you are using a non-root user. We have had this reported by our Kali Linux users so our developers are currently looking into the issue. As ParrotOS is also based on Debian it is likely it suffers from the same issue so I will add these details to the bug report for our developers to investigate. If you are happy running without the sandbox then please do so. We will update this thread when we have some further news on the issue.

Kevin | Last updated: Jul 31, 2020 06:48AM UTC

I'm also having this issue in Kali 2020.2a. Is there a way to run the browser without the sandbox? Thanks!

Kevin | Last updated: Jul 31, 2020 06:48AM UTC

I'm also having this issue in Kali 2020.2a. Is there a way to run the browser without the sandbox? Thanks!

Kevin | Last updated: Jul 31, 2020 06:48AM UTC

I'm also having this issue in Kali 2020.2a. Is there a way to run the browser without the sandbox? Thanks!

Uthman, PortSwigger Agent | Last updated: Jul 31, 2020 09:02AM UTC

Hi Kevin, You can enable the browser without the sandbox under Project options > Misc > Embedded Browser.

You need to Log in to post a reply. Or register here, for free.