Burp Suite User Forum

Login to post

Updates deleting my UserConfigPro.json

Elim | Last updated: Apr 29, 2022 06:48PM UTC

The last two updates (Early Adopter) have completely deleted my UserConfigPro.json file. Which means I have to reinstall my extensions, reset preferences, etc. Is this a bug within the Early Adopter branch? What other information can I provide to help the Burp team troubleshoot?

Ben, PortSwigger Agent | Last updated: May 03, 2022 09:37AM UTC

Hi Elim, We are not aware of any issues with the early adopter updates so it would be good to get some further information from you. Are you able to confirm the following: - What operating system are you using? - Where have you installed Burp on your machine? - Where is the UserConfigPro.json file located? - Which versions of Burp have you upgraded from and to when you have seen this happen?

Elim | Last updated: May 05, 2022 03:18PM UTC

Hi Ben, 1. uname -a Linux secret 5.16.0-kali7-amd64 #1 SMP PREEMPT Debian 5.16.18-1kali1 (2022-04-01) x86_64 GNU/Linux 2. /home/secret/.BurpSuite 3. UserConfigPro.json is located in directory above 4. The last two times I've upgraded. I'm having trouble findings which versions specifically, but right now I'm on Burp Suite professional v2022.3.6-12792(Early Adopter). When I upgraded to my current version is when I experienced the problem. I have recently expanded my diskspace as I was running pretty low. So maybe that will help. In any case, I will report back if this problem persists. Cheers.

Ben, PortSwigger Agent | Last updated: May 06, 2022 08:56AM UTC

Thanks for that Elim. I will see if I can replicate the issue here using a similar setup. Please do report back if this does happen again.

You need to Log in to post a reply. Or register here, for free.