Burp Suite User Forum

Create new post

unusable interface issue

razew | Last updated: Oct 06, 2023 10:58AM UTC

Image previw: https://imgur.com/61GYvxV I just launched Burp and have no idea why it looks like this, I tried reinstalling it and it is the same thing. display settings: res: 1920x1080 dpi: 96

Dominyque, PortSwigger Agent | Last updated: Oct 06, 2023 12:18PM UTC

Hi If you add the option -Dsun.java2d.d3d=false into the vmoptions file in your installation directory, does this help? If it does, you can create a user.vmoptions file in the same folder so that the setting does not get overwritten when Burp upgrades.

razew | Last updated: Oct 06, 2023 04:25PM UTC

It didn't help. The issue is on a VM, but somehow disabling the "Accelerate 3D graphics" option fixed it, whats could be wrong?

Dominyque, PortSwigger Agent | Last updated: Oct 09, 2023 06:56AM UTC

Hi We have seen that this is an issue for some VMware users after an update was made on their side. One user in another forum post has listed these as potential workarounds: - Disabling the 'accelerate 3D graphics' option - Disable Glamor (set XWAYLAND_NO_GLAMOR=1 in /etc/environment, then reboot the system). - Add -Dsun.java2d.opengl=true to /Software/BurpSuitePro/user.vmoptions - user.vmoptions will be preserved even after future Burp software updates

You must be an existing, logged-in customer to reply to a thread. Please email us for additional support.