Burp Suite User Forum

Login to post

Unsupported Operation Exception

Heath | Last updated: May 31, 2016 04:41AM UTC

Using Burpsuite Professional v1.7.03. Java version 1.8.0_91 Operating system 4.5.0-kali1-amd64 (virtual) Have previously used Burpsuite Free version. This has not been removed. Opened Burpsuite Professional for first time using CLI. Entered license key, all good. Delete temporary files, select temporary project, select use burp defaults. Software throws the error message "An error occurred when starting a project with the selected options. java.lang.UnsupportedOperationException". It will let me go back from there but not further. The terminal shows the/an error comes after "at java.awt.Cursor.getSystemCustomCursor(Cursor.java:363)". The error message given is "java.awt.AWTException: Exception: Class java.lang.IllegalArgumentException Width (0) and height (0) must be non-zero occurred while creating cursor CopyDrop.32x32" I get the same results using the -noextensions flag. I get the same results with different RAM limitations. Where to from here?

Burp User | Last updated: May 31, 2016 04:59AM UTC

Problem solved on reboot. (shrug)

PortSwigger Agent | Last updated: May 31, 2016 10:08AM UTC

Thanks for this report. If you run into this problem again, please can you email us your debug ID (at User options / Misc / Performance feedback) and we'll investigate further, thanks.

PortSwigger Agent | Last updated: May 31, 2016 10:09AM UTC

Thanks for this report. Please can you email us your debug ID (at User options / Misc / Performance feedback) and we'll investigate further, thanks. You can just start a default/temporary project to open the main Burp window and view the debug ID.

Burp User | Last updated: Jun 30, 2016 05:13PM UTC

I'm getting this same error now too. Reboots don't help. java.runtime.name OpenJDK Runtime Environment java.runtime.version 1.8.0_77-Debian-8u77-b03-3-b03 os.arch amd64 os.name Linux os.version 4.4.0-kali1-amd64 Are there other settings or details you'd like me to post to assist with this?

Burp User | Last updated: Jul 08, 2016 01:13PM UTC

I resolved this problem on my qemu instance of BlackArch by changing my qemu -vga parameter to -vga virtio. $ /usr/bin/qemu-system-x86_64 -enable-kvm -vga virtio -m 2G...

PortSwigger Agent | Last updated: Jul 11, 2016 09:15AM UTC

Thanks for this report. We'll try to reproduce this problem using the exact version of Java that you have, on Windows 10.

Burp User | Last updated: Jul 15, 2016 01:18PM UTC

Hi, I could not use burp with windows10 with java version "1.8.0_91" Java(TM) SE Runtime Environment (build 1.8.0_91-b14) Java HotSpot(TM) 64-Bit Server VM (build 25.91-b14, mixed mode) After launching with setup wizard. Burp could not run anything.

Liam, PortSwigger Agent | Last updated: Jul 27, 2016 03:06PM UTC

Hi JP We've tested Burp with Java 1.8.0_91 on Windows 10 and haven't been able to recreate your issue. Have you tried using another version of Java?

You need to Log in to post a reply. Or register here, for free.