Burp Suite User Forum

Login to post

Unable to resume Crawl and Audit Scan after consecutive audit items failing

Brandon | Last updated: Aug 14, 2019 03:03PM UTC

Hello, Anytime that I try to run the Crawl and Audit Scan, I run into consecutive audit items failing due to 'Errors: unable to relocate function'. I am then unable to resume the scan/auditing (when I click the play button, it just grays out and the scan does not resume). I have performance feedback enabled, and below is the debug ID: o6frpf501lnvdh2xgouh:qu4b

Rose, PortSwigger Agent | Last updated: Aug 15, 2019 09:50AM UTC

Brandon, thanks for the information and sorry you're having issues. Just to clarify when you say "anytime", do you mean that this is a recurring issue? If so, please can you enable debug mode via Dashboard > New scan > Scan configuration > New > Crawling > Crawl Optimization > click the cog button > Enabling logging. Then reproduce the issue. If you could then send us your crawler log file to support@portswigger.net, please, that would be great.

Liam, PortSwigger Agent | Last updated: Aug 16, 2019 08:03AM UTC

Adam, are you encountering these errors during the crawl or audit stage of a scan? Have you tried using the Flow extension to monitor the traffic causing this error?

Burp User | Last updated: Sep 30, 2019 07:49PM UTC

Any Update on this ?

Burp User | Last updated: Oct 10, 2019 08:43PM UTC

Audit stage, Liam I just installed Flow extension

Mike, PortSwigger Agent | Last updated: Oct 11, 2019 09:42AM UTC

Adam, that configuration will prevent your scan from stopping due to the number of errors, but it won't stop the actual errors themselves from appearing. Have you tried modifying your resource pool configuration?

Burp User | Last updated: Oct 15, 2019 06:47PM UTC

This weekend did a scan on the same website, same issue happens on auditing scanning. It seems to happen after scanning several hours same website. I look at the Flow information same information shows up does not change and the code can be either 200 or 400 does not seem to matter. I was thinking about trying this audit out from the library Never stop audit due to application errors Do you think it would help ?

Mike, PortSwigger Agent | Last updated: Oct 16, 2019 12:57PM UTC

Adam, I have just responded to your thread on that resolution, thank you for sharing it here also. Hopefully, it will help other users with this issue.

Burp User | Last updated: Oct 21, 2019 04:06PM UTC

Mike, I found the answer to this issue which seems to be tied to also this issue Errors: unable to relocate function, well for me at least Created a resource pool with a delay between requests set to 300 milliseconds

You need to Log in to post a reply. Or register here, for free.