Burp Suite User Forum

Login to post

Unable to maintain keep alive connection while using burp suite

Jatin | Last updated: Nov 29, 2019 01:25PM UTC

Hi, I am trying to test a webapp for vulnerabilities. I am using keep alive connections for my app's functioning, it works fine when i am not using burp as a proxy. But i am unable to maintain keep alive connections when using burp. Plese suggest any way to maintain a keep alive connection using burp.

Mike, PortSwigger Agent | Last updated: Dec 02, 2019 11:03AM UTC

Hi Jatin, inside Proxy > Options > Miscellaneous, do you have 'Set 'Connection Close' on incoming requests' enabled? Burp Suite is set by default to automatically close connections as this can often have performance benefits.

Burp User | Last updated: Dec 05, 2019 06:15AM UTC

Hi Mike, I have already tried that but that didn't work in my case.

Mike, PortSwigger Agent | Last updated: Dec 05, 2019 01:31PM UTC

Hi Jatin, I have just spoken to our Burp Suite development team. Burp Suite will automatically close connections when proxying traffic as it provides significant performance and reliability benefits. The setting I referred to previously will stop Burp from injecting a 'Connection: close' header when proxying traffic which can help in certain scenarios, however, it doesn't prevent it from closing the connection.

Burp User | Last updated: Dec 09, 2019 07:44AM UTC

Hi Mike, there must be any particular timeout after which burp closes the connection isn't it ? So, is there any way that i can keep-alive my connection for any period of time like 5 minutes, so that i can test my app's functionalities in that time span.

Mike, PortSwigger Agent | Last updated: Dec 10, 2019 09:47AM UTC

Hi Jatin, unfortunately, the connection will be closed as soon as the response is received. Therefore you will not be able to work around this limitation in that way. When you refer to using Keep-Alive connections for your application, are you using Server-Sent Events? As we have another user asking about this at the moment so we could look into this if it was a requested feature.

You need to Log in to post a reply. Or register here, for free.