Burp Suite User Forum

Login to post

Unable to access labs while proxy on(intercept off), everything except labs works fine

Tushar | Last updated: Sep 26, 2023 11:13AM UTC

Hey, I am recently facing this issue on port swigger labs only. I am unable to access the labs while turning on my proxy. I tried to solve it using regenrating ca certificates, and few more things. But none works. Everything except labs is working good. And sometimes it just keeps on loading for 10-15 minutes, but sometimes it gives me error. One is "Error: Could not create new HTTP/2 connection", and the 2nd error is "Error: No response from the remote server." I even tried to connect it without foxy proxy turned on, it works fine. Also I have checked my proxy configuration, its correctly configured. I dont know where is the issue. I have attached a screen recording for the same. Do let me know how to resolve this: https://drive.google.com/file/d/1O2G8i9VheyKvrWiSFozIdGJr-LMN0tlS/view?usp=sharing

Michelle, PortSwigger Agent | Last updated: Sep 26, 2023 11:45AM UTC

Hi If you use Burp's embedded browser to access the labs, do you see the same problem? When the issue occurs, do you see any messages displayed in the Event Log on Burp's Dashboard? Do you use any upstream proxies? Are you able to access the labs if Firefox is not proxied via Burp?

Tushar | Last updated: Oct 02, 2023 10:05AM UTC

Yes, I face the same problem while using the embedded browser too. There are no messages displayed in event log/dashboard. I use FoxyProxy. And yes, I am able to access the labs if firefox is not proxied via burp.

Michelle, PortSwigger Agent | Last updated: Oct 02, 2023 11:14AM UTC

Hi There are no reported issues with the labs, so this appears to be something environmental. Do you have Burp installed on any other machines or on a virtual machine? If so, do these display the same issue? Can you share a screen recording to show what happens when you try to access the labs using Burp's embedded browser? Do you have any specific user or project options that have been changed away from the defaults? If you try to refresh the page for the lab, does the error stay the same?

You need to Log in to post a reply. Or register here, for free.