Burp Suite User Forum

Transparent proxy (invisible mode) doesn't work for OSX 10.14.6

Eiji | Last updated: Sep 09, 2019 08:52AM UTC

Burp Invisible Proxy doesn't work for OSX 10.14.6 if the Application Firewall is turned on. To proxy HTTP requests from iOS device, I configured testing environment as follows: * I paired iOS device to MacBook via Bluetooth * Internet Sharing (sharing Wi-Fi with Bluetooth PAN) is enabled on Mac OS X * Port forwarding is configured as below (using pfctl) - rdr pass on bridge100 inet proto tcp from any to any port 80:65535 -> 127.0.0.1 port 8080 * Invisible mode is enabled for a listener (listening 127.0.0.1:8080) This method worked for OSX 10.14.4, but doesn't work for 10.14.6. A workaround is to disable Application Firewall on macOS (Go to 'System Preferences -> Security & Privacy -> Firewall', and turn off the firewall.) It might be a bug, because other proxy tools can still work as a transparent proxy for OSX 10.14.6.

Mike, PortSwigger Agent | Last updated: Sep 09, 2019 12:32PM UTC

Hi Eiji, Thank you for bringing this to our attention. Looking at the release notes, there doesn't appear to be anything obvious that could have caused this: https://support.apple.com/en-gb/HT209149#macos10144 Have you tried with version 10.14.5?

You need to Log in to post a reply. Or register here, for free.