Burp Suite User Forum

Create new post

The embedded browser has stopped passing traffic through burp, all site unreachable

Kevin | Last updated: Feb 16, 2022 08:36PM UTC

Hi, For some reason the embedded browser has stopped being able to reach any sites. I don't see any traffic passing through the proxy. I did have the 'allow chrome to save settings' checkbox ticked and have unchecked that, but still the same issue. Any tips on getting the embedded browser reset so that it is useful? Kevin

Ben, PortSwigger Agent | Last updated: Feb 18, 2022 08:05AM UTC

Hi Kevin, Is the Burp Proxy Listener still enabled under Proxy -> Options -> Proxy Listeners within Burp? What is being displayed in your browser when you try and browse to a site using the embedded browser? Finally, I assume that you have already probably done this but, what happens if you simply close and relaunch Burp - do you still have the same issue?

Kevin | Last updated: Feb 23, 2022 07:26PM UTC

Sorry for the delay in getting back to you. Listeners are enables. I can use other browsers through Burp just fine, I just can't use the embedded browser. I get: This site can’t be reachedThe connection was reset. Try: Checking the connection Checking the proxy and the firewall ERR_CONNECTION_RESET

Kevin | Last updated: Feb 23, 2022 08:03PM UTC

Oh, and there is absolutely no evidence that burp saw any traffic from the browser.

Ben, PortSwigger Agent | Last updated: Feb 25, 2022 09:23AM UTC

Hi Kevin, Is it possible for you to send us an email at support@portswigger.net and include some details: - Could we get your diagnostics (via the Help -> Diagnostics menu option) - if there are any messages in the Event log on the Dashboard tab, could we get a screenshot of this - It sounds like this previously worked for you - assuming that is the case, were you in the process of updating Burp or similar when this issue started to occur? - Were any settings in the browser itself changed at any point when you noticed this issue? - Does changing the port that the proxy listener is listening on and closing and reopening the browser improve things for you? A quick solution might be to attempt a reinstallation of Burp (so that the embedded browser reverts back to its original configuration)

Syed | Last updated: Jun 18, 2024 12:38AM UTC

I am having the same issue

Syed | Last updated: Jun 18, 2024 05:49AM UTC

reinstallation doesn't seem to help were you able to find a fix for this ?

Hannah, PortSwigger Agent | Last updated: Jun 18, 2024 03:27PM UTC

Hi Are you able to send a request to the target endpoint in Repeater, or does that also fail? You can quickly generate a Repeater request by copying the URL of your target site to your clipboard, then in Repeater, right-clicking and using "Paste URL as request". After that, you can press the "Send" button to issue the request.

You must be an existing, logged-in customer to reply to a thread. Please email us for additional support.