Burp Suite User Forum

Login to post

"Support HTTP/2" checkbox not working in proxy settings

Mehran | Last updated: May 08, 2022 10:35AM UTC

Even after disabling "support HTTP/2" in proxy settings requests still have HTTP/2 header and disabling the checkbox does not apply. It is not possible to interact with HTTP/1.1 sites and the following error is shown: RST_STREAM received with error code: 0xd (Use HTTP/1.1 for the request) It is worth mentioning that by manually setting HTTP/1.1 in repeater everything works well.

Michelle, PortSwigger Agent | Last updated: May 09, 2022 09:55AM UTC

Thanks for your message. Are you seeing this issue with a particular site? If so are you able to share the details of the site with us? You can email them to support@portswigger.net if you'd prefer not to share this information on the forum. When you disable 'Support HTTP/2' on the proxy listener, this will control the settings used between the client browser and Burp's Proxy Listener. Have you tried disabling Project Options -> HTTP -> HTTP/2 -> 'Default to HTTP/2 if the server supports it' to control the settings used when Burp negotiates the settings with the server?

Mehran | Last updated: May 09, 2022 10:26AM UTC

That actually solved the problem. It was a great hint by the way. Thanks.

You need to Log in to post a reply. Or register here, for free.