Burp Suite User Forum

Login to post

sni problem

Gutreiman, | Last updated: Aug 01, 2023 02:17PM UTC

after the last update I have in my repeater the option for sni override whether I turn it on/off in repeater or on/off settings I got many error connections such as 403 for urls that worked before the update and also are working now in postman which means my experience with burp suite have been degraded as a result the last update also I have this error in my dashboard:"failed to connect to the configured collaborator server: polling.oastify.com"

Ben, PortSwigger Agent | Last updated: Aug 02, 2023 10:18AM UTC

Hi Avraham, If the Repeater SNI override option is left alone then this should work in exactly the same manner as previous versions of Burp (The 403 responses would also indicate that the TLS handshake has actually succeeded) so it is interesting that you are now having issues. Are any of the sites that you are now experiencing issues with public facing and ones we could look at ourselves? In addition to the above, and just to confirm, this option should not impact the Collaborator polling. Is it possible that some other changes have taken place in your environment? If you run the Burp Collaborator health check (via the Settings -> Project -> Collaborator -> Run health check button), what output do you receive?

You need to Log in to post a reply. Or register here, for free.