Burp Suite User Forum

Login to post

Scope Bug

Chunqi | Last updated: Apr 07, 2021 07:12AM UTC

Description Show only in-scope items filter is not functional when opening a Burp project that already has the option enabled. The filter works correctly when re-applied manually. Version v2021.3.1 Reproduction Steps 1. Create a new project on disk 2. Add https://www.google.com/ to scope 3. In Proxy -> HTTP history set filter to Show only in-scope items 4. Close Burp 5. Re-open the project 6. Resume tasks and disable intercept 7. Browse to https://www.apple.com/ 8. Proxy -> HTTP history shows all requests to apple.com even though Show only in-scope items filter is active

Ben, PortSwigger Agent | Last updated: Apr 08, 2021 07:21AM UTC

Hi, Thank you for this. We will see if we can replicate this issue and get back to you if we require any further information or clarification.

Uthman, PortSwigger Agent | Last updated: Apr 12, 2021 08:14AM UTC

Hi Chunqi, Did you select 'Yes' on the popup after adding to https://www.google.com/ to scope in step 2 of your replication steps?

You need to Log in to post a reply. Or register here, for free.