Burp Suite User Forum

Login to post

Scanner does not work with NTLM auth

Alessandro | Last updated: Sep 15, 2020 09:53AM UTC

The scanner times out when going through socks proxy with NTLM auth. This issue is not present in burp 2020.5. The problem was found in all versions above 2020.5

Michelle, PortSwigger Agent | Last updated: Sep 15, 2020 10:18AM UTC

Thanks for your message. Are you able to browse the same site successfully using Burp Proxy? Which version of NTLM are you using?

Alessandro | Last updated: Sep 15, 2020 12:26PM UTC

Yes the issue is present only in the Scanner. Intruder, Proxy and Repeater works correctly. I'm using NTLMv1 but the bug is present also with v2.

Michelle, PortSwigger Agent | Last updated: Sep 15, 2020 12:39PM UTC

Thanks for the update. Can I confirm if you are using the embedded browser for scanning in version 2020.9 and 2020.9.1? This is turned on by default in these versions and is configured by editing the crawl configuration under Miscellaneous ->Embedded Browser Options.

Alessandro | Last updated: Sep 15, 2020 01:37PM UTC

No i'm using Firefox as browser

Michelle, PortSwigger Agent | Last updated: Sep 15, 2020 01:46PM UTC

Are you manually crawling the site and then launching the scan by going to the Target tab and using the right-click menu to choose Scan -> Audit Selected items? If not can you describe how you start the scan, please?

Alessandro | Last updated: Sep 15, 2020 02:01PM UTC

I manually crawl the site and i define the insertion points using the Intruder and then i choose "Scan defined insertion points"

Michelle, PortSwigger Agent | Last updated: Sep 15, 2020 02:31PM UTC

Thanks for confirming those details. Based on your description, I'm afraid the issue you are having appears to match a bug that has recently been reported to us. I have linked this thread to the bug report so we can let you know when a fix for this is released.

You need to Log in to post a reply. Or register here, for free.