Burp Suite User Forum

Login to post

SAML Raider "failureInInitialization" with BurpSuite v2021.9.1 Build 10295

Ryan | Last updated: Nov 12, 2021 03:48PM UTC

Normally, the SAML Raider extension will populate a SAML Raider tab when you select a SAML request in the HTTP History. Now, instead of populating the tab, it shows the error: <SAMLRaiderFailureInInitialization></SAMLRaiderFailureInInitialization> I suspect this is due to a recently applied update as it worked before the update. I re-installed the SAML Raider extension, and no change.

Hannah, PortSwigger Agent | Last updated: Nov 15, 2021 03:30PM UTC

Hi I've been doing some testing with some sample SAML requests, and it seems that this issue was introduced in the Early Adopter release of v2021.9. This is the site with some sample messages: https://docs.akana.com/cm/saml/04_req_resp_metadata.htm It seems that the extension is working with some requests, but some others cause that error. Are you experiencing the same behavior, or is it failing for every request?

Ryan | Last updated: Nov 20, 2021 04:21PM UTC

Hi, It was an intermittent problem in v2021.9. Some SAML messages worked while others didn't, even within the same HTTP history. I recently upgraded to v2021.10 build 10565 and the issue seems to have gone away.

Hannah, PortSwigger Agent | Last updated: Nov 22, 2021 01:12PM UTC

Thanks for that information! If this issue recurs then please let us know.

You need to Log in to post a reply. Or register here, for free.