Burp community forum

Render broken in latest version - 2.0.22

Martin | Last updated: May 26, 2019 06:52PM UTC

Hello, in the latest version 2.0.22 the 'render' function is broken. Not only it opens in an external window now, which is unacceptable, but it displays only a blank page, always. It was working FINE in the previous version. Whatever you changed in this version please undo it.

Burp User | Last updated: May 27, 2019 05:43PM UTC

I can confirm this behavior: i'm on Kali Linux (latest), Oracle JRE1.8 and starting with 2.0.22 i cannot Render pages anymore: https://i.imgur.com/4owkR1W.png Starting from the command line will not help in debugging or pinpointing the issue since no messages are visible: is there any switch to raise the stdout logging level?

Rose, PortSwigger Agent | Last updated: May 28, 2019 07:56AM UTC

Martin, when you say this worked fine in the previous version, can you confirm that you mean 2.0.21? Thanks.

Rose, PortSwigger Agent | Last updated: May 28, 2019 08:35AM UTC

Please could you both send an email to support@portswigger.net with your diagnostics (Help > Diagnostics)?

Burp User | Last updated: May 28, 2019 12:33PM UTC

Hello I confirm the same behavior burp suite pro v2.0.22 Linux environment always I receive errror " Embedded browser initialization failed" , I have downgraded to version to 2.0.20 working well... /alt3kx

Liam, PortSwigger Agent | Last updated: May 28, 2019 12:46PM UTC

/alt3kx, could you send an email to support@portswigger.net with your diagnostics (Help > Diagnostics)?

Burp User | Last updated: May 28, 2019 03:04PM UTC

Diagnostics sent!

Liam, PortSwigger Agent | Last updated: May 28, 2019 03:07PM UTC

Thanks Martin. We'll update you when we've made some progress.

Burp User | Last updated: May 30, 2019 11:02AM UTC

Diagnostics sent!

Liam, PortSwigger Agent | Last updated: May 30, 2019 11:05AM UTC

Thanks for your feedback. We implemented the new browser in this way due to the complicated nature of the integration. We have a story in our dev backlog to implement remote rendering in to Burp tabs. Unfortunately, we can't provide an ETA. Please let us know if you need any further assistance.

Burp User | Last updated: Jun 03, 2019 05:31PM UTC

The issue persists in the latest version 2.0.23. Windows 10 Pro Version 1809 – Build 17763.529 Regards, Martin Fürholz

Burp User | Last updated: Jun 04, 2019 04:11AM UTC

@Rose: The render version was broken for me in v2.0.21 and 2.0.22. It was working flawlessly in v2.0.20 (i.e. when we could render without the pop-up window). Just upgraded to v2.0.23 and the issue still persists.

Burp User | Last updated: Jun 12, 2019 06:10PM UTC

In the latest beta version 2.0.24 the render is not *completely* broken anymore. But still extremely badly broken. But it opens in a new window (which makes it pretty unusable, seriously!) and the rendered page only makes up 1/4th of the window. This still is *extremely badly broken*. Please bring the rendered page back in the tab directly. Not in a new window.

Burp User | Last updated: Jun 12, 2019 06:12PM UTC

I use it mostly to quickly check things – and having to click on a button, then wait for it to load in a new window is extremely annoying.

Burp User | Last updated: Jun 27, 2019 01:38AM UTC

How come you didn't do proper sanity testing of it, after 'implementing' a new browser? How can it be so important to break the old, working browser, but then kind-of 'forget' to test it on Windows 10?

You need to Log in to post a reply. Or register here, for free.