Burp community forum

Proxy intercept not working with firefox

seackei | Last updated: Aug 19, 2019 07:00PM UTC

Im using firefox to run test my website on localhost.I configured the proxy settings so that burp suite can intercept it.But with all the correct settings,the traffic is still not intercepted.Yesterday it was working fine,i went to sleep woke up and its not working anymore. Configurations I used : https://imgur.com/a/wdhcfv7

Burp User | Last updated: Aug 20, 2019 05:23AM UTC

Ur firefox setting proxy is wrong.You need to remove "localhost,127.0.0.1" from the no proxy fields box.

Ben, PortSwigger Agent | Last updated: Aug 20, 2019 11:40AM UTC

Hi, As Mekadon has noted, removing the entries from the No proxy for field should resolve this issue.

Burp User | Last updated: Nov 08, 2019 07:42AM UTC

Go to about:config in firefox Chang the firefox setting network.proxy.allow_hijacking_localhost to true

Burp User | Last updated: Jan 01, 2020 03:57PM UTC

For the latest versions of Firefox, MTK's answer is correct. network.proxy.allow_hijacking_localhost needs to be altered now.

You need to Log in to post a reply. Or register here, for free.