Burp Suite User Forum

Create new post

Private Burp Collaborator ignoring polling Port settings (?)

Mopam | Last updated: Jan 06, 2024 06:33PM UTC

I've set up my private collaborator and everything work as expected, except for the fact that I keep polling it without specifying the port and it works fine when I actually have set specific polling ports in the .config: "polling": { "http": { "port": 9090 }, "https": { "port": 9443 }, "ssl": { "certificateFiles" : [ "/root/burpcollaborator/certs/1.key.pkcs8", "/root/burpcollaborator/certs/2.crt", "/root/burpcollaborator/certs/intermediate.crt" ] } } So technically I should only be able to poll the collaborator by setting Burpsuite Private Collaborator settings section to use port 9443 (or 9090 if http only box is flagged). The problem here is that if I attempt to poll it over 9443/9090 it does not work. Is this behavior expected?

Michelle, PortSwigger Agent | Last updated: Jan 08, 2024 08:49AM UTC

Hi What errors do you see if you configure Settings > Project > Collaborator > Burp Collaborator server > Polling location to be you-collaborator-server:9443? Are your firewall rules configured to allow access on port 9443?

You must be an existing, logged-in customer to reply to a thread. Please email us for additional support.