Burp Suite User Forum

Login to post

NoPE Proxy Tab wont show

Bassem | Last updated: Apr 28, 2021 12:51AM UTC

Hello, I'm using Burp suite community Edition v1.7.36 and I have loaded successfully the extension manually through the BApp Store and I have used it for many hours. Now, the NoPE Proxy Tab disappeared and I tried the following steps to get it back: -Reinstall it through BApp Store extensions lists. -Load the NoPE Proxy jar file from the Extensions Tab and the extension loaded successfully without any error but the Tab wont appear. - Delete Burp suite and it's temp files then re try to load it but same issue. I dont know if this may happened when I have checked/unchecked Extension Loaded option in the Extensions Tab for the NoPE Proxy extension. *Installing another extension works fine and it's tab appears + I have tried also on Burp suite community Edition v2021.4.2 but doesn't work. Is the problem caused by some temp/config files that wont be deleted on uninstallation? and Can you please provide me a solution to reget the NoPE Proxy Tab again? Thanks in advance,

Bassem | Last updated: Apr 28, 2021 10:49AM UTC

Hello, I remember also Burp freezes while using the NoPE Proxy Tab then I was forced to end it's task in way to re use Burp and when I reopened burp the tab was disappeared and cannot reget it. Thanks,

Hannah, PortSwigger Agent | Last updated: Apr 28, 2021 11:15AM UTC

Hi Did you have any other extensions installed at the same time as NoPE Proxy?

Bassem | Last updated: Apr 28, 2021 11:50AM UTC

Hello, Yes, I have the Random IP Address Header extension and its Tab is showing properly.

Hannah, PortSwigger Agent | Last updated: Apr 29, 2021 03:13PM UTC

Hi Could you try uninstalling all other extensions and then reloading NoPE Proxy? We've just tried loading it in on both v1.7.37 and the latest version of Burp, and it has loaded in fine. It does take a few seconds to load though. Could you also check that you have performance feedback enabled, and if you do, send us your Debug ID? You can find this by going to "User options > Misc > Performance feedback".

Bassem | Last updated: Apr 29, 2021 08:21PM UTC

Hello, Thanks for the updates. I tried to remove all extensions and then re-add the NoPE Proxy extension as you suggested but the tab still doesn't appear. (Added though a .jar file from the Extensions Tab) >>We've just tried loading it in on both v1.7.37 and the latest version of Burp, and it has loaded in fine. It does take a few seconds to load though. Yes, it works I have already used the NoPE Proxy extension on this version until my burp suite crashed while using the extension Tab. After that, the extension disappeared and I wasn't able to reload it anymore. Please find below my Debug ID: jdo7k07j345vf97f12dk:6g0a Thanks,

Hannah, PortSwigger Agent | Last updated: Apr 30, 2021 11:17AM UTC

Hi

Thank you for that information.

You are getting a lot of errors reported from your installation ID that are to do with NoPE Proxy.

Could you try deleting the NoPE Proxy folder that is located at "~/.NoPEProxy", then reinstalling the extension?

Do you have any further details on the actions you were performing before this issue was triggered? We would recommend raising the issue with the developer of the extension here

Bassem | Last updated: Apr 30, 2021 01:50PM UTC

Hello, Deleting the ".NoPEProxy" folder as you suggested have solved the issue and the Tab will load properly. Thank you for your support and time.

Hannah, PortSwigger Agent | Last updated: May 03, 2021 03:46PM UTC

Glad to hear it! If this happens again, we would highly recommend raising this with the extension author.

You need to Log in to post a reply. Or register here, for free.