Burp Suite User Forum

Create new post

No UI after launching BUrp from command line

Umang | Last updated: Jul 23, 2015 11:54AM UTC

When I try to launch Burpsuite v1.6.01 from my 32-bit Ubuntu-12.04LTS, it shows message "Proxy:Proxy service started on" but no UI is displayed means Burpsuite App is not launched. -My PC has a second partition in which I have installed Windows 7. -I have downloaded burpsuite from official site "burpsuite_free_v1.6.01.jar". -I am using command "sudo java -jar burpsuite_free_v1.6.01.jar" -My java version is 1.6.0_35. {java version "1.6.0_35" OpenJDK Runtime Environment (IcedTea6 1.13.7) (6b35-1.13.7-1ubuntu0.12.04.2) OpenJDK Server VM (build 23.25-b01, mixed mode)} -I was using same version in 64-bit machine with same steps I follow here. Please help me out as I have in urgent need !!! Thanks in Advance

PortSwigger Agent | Last updated: Jul 23, 2015 12:15PM UTC

This indicates that Burp is running in headless mode. The key indicator is that the message about the proxy, which would normally show in the in-UI alerter, is being printed to the console. Headless mode can be specified with a command line flag. Since you haven't specified this, the likely explanation is that your Java installation doesn't have support for a full Swing UI. You should try and install a full version of Java that includes this.

Burp User | Last updated: Aug 05, 2015 06:57AM UTC

I have tried installing JAVA again. using- {sudo apt-get install openjdk-6-jre} still facing the same problem. Can u help?

Burp User | Last updated: Aug 05, 2015 11:43AM UTC

One more thing: I have dual boot machine having Windows 7 installed which is 64-bit while Ubuntu installed is 32-bit.

PortSwigger Agent | Last updated: Aug 10, 2015 11:10AM UTC

Your earlier output indicated that you have a server JVM installed, which probably doesn't include a desktop UI. We would recommend installing the desktop version of Java.

You must be an existing, logged-in customer to reply to a thread. Please email us for additional support.