Burp Suite User Forum

Login to post

License is suddenly invalid, even though it should expire in November

Ozge | Last updated: May 24, 2023 11:03PM UTC

Hello When opening the application this morning we found that BurpSuite is asking for the license key, and after providing the key that should be valid until November 2023 it says it's invalid. Logging on to the portal to retrieve a (supposedly) new key, we are told that the key is only available to the license holder (which is me) and is now inaccessible. Can you please advise? Our personnel relies on Burpsuite to do their job. Thank you

Ozge | Last updated: May 24, 2023 11:29PM UTC

Never mind. I subsequently found about the new individual activation requirement and everything is ok now. For reference: https://portswigger.net/burp/account-and-subscription-management/account-management

Ben, PortSwigger Agent | Last updated: May 25, 2023 07:14AM UTC

Hi Ozge, You are correct - we have now moved to a mandatory system whereby account holders need to invite their team and allocate users individual licenses. Glad to hear that you have now resolved this.

Lana | Last updated: May 26, 2023 06:27AM UTC

Hello, We have the same issue and our licenses are also valid till November, I followed the steps on the document https://portswigger.net/burp/account-and-subscription-management/account-management But after assigning license to team members they are not receiving any mail about the activation. Thanks.

Michelle, PortSwigger Agent | Last updated: May 26, 2023 07:25AM UTC

Hi Thanks for your message. I can see that some emails have been sent to some users. Can you ask them to check if the email has been added to their spam or junk folders? If they still can't find the emails, can you please email hello@portswigger.net with details of some of the users who have not received their emails so we can take a closer look?

Lana | Last updated: May 26, 2023 08:55AM UTC

Hello Michelle, Thanks for your response, I have dropped an email to hello@portswigger.net with the user list. None of them received activation email. Thanks!

Lana | Last updated: May 31, 2023 03:11AM UTC

Hello Michelle, We still have problem with the license, I sent multiple emails to hello@portswigger.net but received no response. No one in my org is able to use the tool currently and it is now becoming critical. Is there any other way to contact support team to help solve the licensing problem? Thanks.

Michelle, PortSwigger Agent | Last updated: May 31, 2023 08:01AM UTC

Hi I can see one of your colleagues has emailed hello@portswigger.net, and we have replied, although, from a later response, your colleague may not have received our reply. As a company, are you receiving any emails from either hello@portswigger.net or licensing@portswigger.net? We have sent you multiple emails from both of these addresses. If these have not arrived and are not in your spam/junk folders, can you check with your IT team to see f these have been blocked elsewhere?

Lana | Last updated: May 31, 2023 02:39PM UTC

Hi Michelle, Thanks for your response! seems like emails were blocked internally, I have them unblocked now and we received the activation emails. Thanks for your support. Thanks!

Michelle, PortSwigger Agent | Last updated: May 31, 2023 02:44PM UTC

Thanks for the update :) It's good to know that's all working now. If you have any further issues, please let me know.

You need to Log in to post a reply. Or register here, for free.