Burp Suite User Forum

Login to post

[Lab] Lab status not updating after being solved

Steven | Last updated: Sep 09, 2022 02:27PM UTC

Hello, I've solved the "User ID controlled by request parameter with data leakage in redirect" several times now, but my account status does not get updated. Neither the lab list page nor the lab description page shows the status as solved, but if I enter into the lab it indicates it has been solved. If I log out and back in again then it shows the lab as unsolved when I enter the lab from the description and I can again solve the lab, but the status still does not update. Lab: https://portswigger.net/web-security/access-control/lab-user-id-controlled-by-request-parameter-with-data-leakage-in-redirect

Michelle, PortSwigger Agent | Last updated: Sep 09, 2022 02:38PM UTC

Thanks for getting in touch. We are aware of this issue and are currently investigating. We'll be in touch once we have a further update from the team.

Michelle, PortSwigger Agent | Last updated: Sep 12, 2022 08:05AM UTC

Thanks for your patience. The labs you completed on Friday should now be showing as solved in your PortSwigger account. Any new labs you complete should also update. Please let us know if any of you have further problems.

You need to Log in to post a reply. Or register here, for free.