Burp Suite User Forum

Create new post

Lab: CL-TE request smuggling lab is not working with the official solution

Anoop | Last updated: Apr 12, 2023 02:26PM UTC

POST / HTTP/2 Host: 0a6f004904bb0b7282f5067100c70057.web-security-academy.net Content-Type: application/x-www-form-urlencoded Content-Length: 6 Transfer-Encoding: chunked 0 G I am referring to your March 14th, 2023 solution. Changed the http2 to http1.1 but the issue is when sending this request it automatically changes to http 2. Can u help me to solve this?

Ben, PortSwigger Agent | Last updated: Apr 13, 2023 06:36AM UTC

Hi Anoop, You need to change the protocol being used within Inspector. If you expand the 'Request attribute' section within Inspector and then toggle the HTTP/1 option for the Protocol setting this should ensure that your Repeater request is sent using HTTP/1.

You must be an existing, logged-in customer to reply to a thread. Please email us for additional support.