Burp Suite User Forum

Login to post

JRE Warning

Sairam | Last updated: Feb 07, 2020 04:19PM UTC

Your JRE appears to be version 13.0.1 from oracle Corporation Burp has not been fully tested on this platform and you may experience problems. Please, help me how to use burp withour this error? Thanks.

Hannah, PortSwigger Agent | Last updated: Feb 07, 2020 04:26PM UTC

The Java version that Burp is fully tested on is OpenJDK 12.0.2 You should be able to use Burp normally with Java 13 so, unless you are encountering any other errors, you can ignore this one.

Vinay | Last updated: Jan 08, 2021 02:20AM UTC

I am seeing similar JRE version warning with my setup: BS professional version=2020.12.1, and Oracle OpenJDK version = 15 GA (build 15+36) Is there a documentation on which was fully tested/supported version of JRE with specific version of Burpsuite?

Vinay | Last updated: Jan 08, 2021 03:49AM UTC

Also, in my env (Oracle OpenJDK 15, and BSP 2020.12.2) console shows following warning: Your JRE appears to be version 15 from Oracle Corporation Burp has not been fully tested on this platform and you may experience problems. WARNING: An illegal reflective access operation has occurred WARNING: Illegal reflective access by burp.c6d (file:/C:/Stage/soa_burp/lib/Burp SuiteLatest.jar) to method java.lang.ClassLoader.defineClass(java.lang.String,by te[],int,int) WARNING: Please consider reporting this to the maintainers of burp.c6d WARNING: Use --illegal-access=warn to enable warnings of further illegal reflect ive access operations WARNING: All illegal access operations will be denied in a future release

Hannah, PortSwigger Agent | Last updated: Jan 08, 2021 08:55AM UTC

Hello The current JRE that is packaged with the platform/installer version of Burp is OpenJDK 14.0.2+12-46 Our minimum supported version of Java is currently Java 9. You shouldn't have any issues with Java 15.

Vinay | Last updated: Jan 08, 2021 05:22PM UTC

Thanks Hannah for the confirmation, but the warning message was scary [hit or miss] about "Your JRE appears to be version 15 from Oracle Corporation Burp has not been fully tested on this platform and you may experience problems." We are using BS from CLI, and only consume .jar. Hence, it would nice if there a note/doc about what version of JRE is fully tested/supported with specific version of Burp Suite. Is such information(documentation) available? Thanks, Vinay

Hannah, PortSwigger Agent | Last updated: Jan 11, 2021 11:27AM UTC

Hi Vinay When we update the JRE version we do include this in the release notes. You can see this in the last updates that we updated the packaged JRE with: - https://portswigger.net/burp/releases/professional-community-2020-5?requestededition=professional - https://portswigger.net/burp/releases/professional-community-2020-4?requestededition=professional

Vinay | Last updated: Jan 11, 2021 06:18PM UTC

Thanks for the info. I am just trying to make a point here, its not ideal for user to dig every single release notes to find such details. Example, What if user of older version of BS (2.1.xx) wants to upgrade to latest version of BSP (2020.12.1)? JRE version information is not available https://portswigger.net/burp/releases/professional-community-2020-12-1?requestededition=professional -Vinay

Hannah, PortSwigger Agent | Last updated: Jan 13, 2021 02:13PM UTC

Hi Vinay Thank you for your feedback. Our Java version does not change very often - we include our minimum Java requirements in the following part of the documentation: https://portswigger.net/burp/documentation/desktop/getting-started/launching/command-line

Vinay | Last updated: Jan 15, 2021 06:15AM UTC

Thanks Hannah.

You need to Log in to post a reply. Or register here, for free.