Burp Suite User Forum

Create new post

Issues with localhost connection in Burp Suite v2024.4.5 on Windows 11 with Firefox (Angular localhost)

Gregor | Last updated: Jun 12, 2024 03:20PM UTC

Hello everyone, I have a problem and hope for your support. System Information: - Windows 11 - Burp Suite Community Edition v2024.4.5 - Firefox 127.0 Problem: I cannot connect to localhost via HTTP proxy on Windows 11 with Firefox. For example, when running an Angular application on localhost:4200, it is not recognized by Burp Suite. Actions Taken: - The browser proxy was correctly set. - I tried the recommended Firefox settings (e.g., setting network.proxy.allow_hijacking_localhost to true), but it didn't help. - Services running in Docker containers work without problems and are recognized by Burp Suite. - Everything works fine in OWASP ZAP. Error Messages: The following event log messages are shown in Burp Suite when I try to access my Angular application via localhost:4200: - Time: 17:14:17 12 Jun 2024 - Type: Error - Source: Proxy - Message: Failed to connect to localhost In the browser, only a Burp Suite website is displayed with the following content: Error An unknown error occurred. I urgently need help, as my customer is experiencing the same issues. Thank you in advance!

Michelle, PortSwigger Agent | Last updated: Jun 13, 2024 09:08AM UTC

Hi Do you see the same error if you use Burp's embedded browser? Does your Burp installation use an upstream proxy? Do you hvae any extensions installed? Are you able to send a request to this application from Repeater? If not, what errors do you see?

Gregor | Last updated: Jun 13, 2024 11:13AM UTC

Hi, Yes, unfortunately, I get the same errors with the embedded browser. No, Burp Suite is the only proxy server running on my computer. The embedded browser runs without any extensions, and I get the same error, so I can rule out that extensions are the issue. When I send a request with the Repeater, I get the following error: Failed to connect to localhost:4200. A friend tried the same setup on his Windows 11 and also cannot access his localhost, except when it comes from a Docker container. Thank you for your help!

Michelle, PortSwigger Agent | Last updated: Jun 13, 2024 01:34PM UTC

If you run a packet trace, do you see any packets leaving Burp going to the application on port 4200? If you use netstat to check for port 4200, what does the output show?

Gregor | Last updated: Jun 15, 2024 12:46AM UTC

I ran a "Hello World" Node.js project on port 3000 as a test, and it worked. However, when I ran an Angular project on the same port (3000), it did not work. It seems to be related to the live server used by Angular. Under the hood, it might be webpack-dev-server, vite, or esbuild. The question is, why does it work without any issues with OWASP ZAP? Netstat shows that the port is listening, but Burp Suite does not forward to the port. I even reinstalled Burp Suite with the default settings. Without the Burp proxy, everything works locally without any problems. A friend of mine has the same issues. Thank you for your help!

Hannah, PortSwigger Agent | Last updated: Jun 17, 2024 01:59PM UTC

Hi For now, let's focus on getting a valid response back in Repeater. This is because it involves an outgoing request from Burp to your application, rather than having an additional step with the browser proxying traffic through Burp as well. In your Repeater request, can you pop open the "Request attributes" section of your Inspector panel. Is a particular HTTP protocol highlighted, or are both unhighlighted? Could you try clicking on "HTTP/1" and sending a request, then clicking on "HTTP/2" and sending a request? Was there a difference in response when sending with either protocol? Could you also send a quick "curl" command to your endpoint in the command line (not proxied through Burp) and observe the response from that? Does that return with a 200 and the appropriate content in the response?

Gregor | Last updated: Jun 17, 2024 04:24PM UTC

Hi, I tried it through the Repeater with both HTTP/1 and HTTP/2, but I am not getting any response. I have recorded everything on video. The video also shows how it works with OWASP ZAP. Here is the link to the video: https://1drv.ms/v/s!AsQ9mrxpUqTTru9ZUPhtmdTavwFLrQ?e=zHxKbV Thank you for your help!

Hannah, PortSwigger Agent | Last updated: Jun 18, 2024 03:18PM UTC

Thanks for the video! We'll review this and get back to you with some next steps. It may be best to continue this thread over email, which will make it easier with regard to attachments. Is it possible for you to drop us an email at support@portswigger.net?

Gregor | Last updated: Jun 19, 2024 08:51AM UTC

Hi Hannah, I wanted to let you know that I've sent you an email detailing the issue with Burp Suite and the localhost connection on Windows 11, as you suggested. Please check your inbox for more information. Best, Gregor

Hannah, PortSwigger Agent | Last updated: Jun 19, 2024 10:59AM UTC

Hi Gregor Thanks for that! We'll continue to provide support through email.

You must be an existing, logged-in customer to reply to a thread. Please email us for additional support.