Burp Suite User Forum

Login to post

Issues with Burp Suite and older iPhone after Macbook update to Big Sur

Harry74 | Last updated: Apr 24, 2021 09:39PM UTC

I've been using burp suite for several years on a 2013 Macbook Pro with several different iPhone models. Yesterday I upgraded the OS on my Macbook from High Sierra to Big Sur. Everything works as it did before the upgrade when watching traffic from my iPhone 12 running iOS 14.1. However, I do a lot of testing using an older iPhone 7 running iOS 10.3. After my Macbook update to Big Sur, I'm getting bizarre behavior. Apps that make API calls over https are not going through, and when I try to view some websites I'm seeing raw http responses in Safari but the pages aren't rendering. Everything was working fine 24 hours ago, and I've been running the latest version of Burp for at least the past few months. Any ideas? I was able to reach http://burp and reinstalled the certificate on the iPhone 7 but it didn't change any behavior. Thanks!

Harry74 | Last updated: Apr 24, 2021 10:37PM UTC

Small update... I still have Burp Suite Free v1.7.19 on my Macbook as well, and I'm able to view my iPhone 7 traffic without any issues. So, there's definitely something funny happening with the current version of Burp and Big Sur. No clue why though!

Hannah, PortSwigger Agent | Last updated: Apr 26, 2021 09:15AM UTC

Hi Have you tried disabling TLSv1.3 in the latest Burp? You can find this option under "Proxy > Options > Proxy listeners > Edit > TLS protocols > Use custom protocols".

Harry74 | Last updated: Apr 26, 2021 05:21PM UTC

Hi - Thanks for the suggestion. Just tried it but no change in behavior.

Hannah, PortSwigger Agent | Last updated: Apr 27, 2021 02:30PM UTC

Could you tell me the version of Burp you are using that is having issues on Big Sur?

To clarify:
  • Your iPhone 12 is able to proxy fine
  • Your iPhone 7 is only working with v1.7 of Burp
Have you tried using any later versions of Burp with your iPhone 7? For example, any versions past v2.x.

Current and previous releases of Burp can be found here.

Harry74 | Last updated: Apr 29, 2021 10:04PM UTC

Hi - I'm running Burp Suite Community Edition v2021.4.2 on Big Sur v11.2.3. My iPhone 12 running iOS 14.1 works fine with this version of Burp My iPhone 7 running iOS 10.3 does not work with Burp v2021.4.2, but it does work with Burp Suite Free Edition v1.7.19 I've not invested the time to try any other versions since I seem to have a workable (though somewhat inconvenient) solution for now Thanks

Hannah, PortSwigger Agent | Last updated: May 03, 2021 03:53PM UTC

Hi Have you tried disabling HTTP/2 under "Project options > HTTP > HTTP/2" (in the latest Burp)? Could you try proxying portswigger-labs.net? Does the site load in the browser or do you see any errors on the site or within Burp itself? This site is a sandboxed domain containing intentional vulnerabilities. You could also try proxying portswigger.net if you prefer.

You need to Log in to post a reply. Or register here, for free.