Burp Suite User Forum

Issues while updating BurpSuite Enterprise version to 2020.1

Eduardo | Last updated: Jan 31, 2020 02:14PM UTC

Hi, while installing the update of burpsuite enterprise via the web interface the installation just hanged and now we are not able to login via web. Went to the logfiles and this is the excerpt from the "supervisor_enterpriseServer" file Jan 31, 2020, 3:07:25 PM INFO: Running (enterpriseServer/.supervise): [E:\Program Files\burpsuite_enterprise/enterpriseServer/host.bat] Jan 31, 2020, 3:07:25 PM INFO: Started child 7432 [user: Optional[NT AUTHORITY\NETWORK SERVICE], cmd: C:\Windows\System32\cmd.exe, startTime: Optional[2020-01-31T14:07:25.757Z], totalTime: Optional[PT0S]] E:\Program Files\burpsuite_enterprise\enterpriseServer>?@echo off '?@echo' is not recognized as an internal or external command, operable program or batch file. E:\Program Files\burpsuite_enterprise\enterpriseServer>set /p JRE_HOME= 0<.jreHome E:\Program Files\burpsuite_enterprise\enterpriseServer>set /p COMPONENT_NAME= 0<.component E:\Program Files\burpsuite_enterprise\enterpriseServer>set /p COMPONENT_VERSION= 0<.version E:\Program Files\burpsuite_enterprise\enterpriseServer>set filename="E:\Program Files\burpsuite_enterprise\enterpriseServer\.supervise" E:\Program Files\burpsuite_enterprise\enterpriseServer>for %F in ("E:\Program Files\burpsuite_enterprise\enterpriseServer\.supervise") do set COMPONENT_INSTALL_ROOT=%~dpF E:\Program Files\burpsuite_enterprise\enterpriseServer>set COMPONENT_INSTALL_ROOT=E:\Program Files\burpsuite_enterprise\enterpriseServer\ E:\Program Files\burpsuite_enterprise\enterpriseServer>set SUPERVISOR_UPDATE_CONTROL_FILE=E:\Program Files\burpsuite_enterprise\enterpriseServer\.runUpdate E:\Program Files\burpsuite_enterprise\enterpriseServer>echo E:\Program Files\burpsuite_enterprise\enterpriseServer\ E:\Program Files\burpsuite_enterprise\enterpriseServer\ E:\Program Files\burpsuite_enterprise\enterpriseServer>IF EXIST ".runUpdate" ( echo "Will update enterpriseServer" call updater.bat ) ELSE ( echo "Will run enterpriseServer 2020.1-2902" call component.bat ) "Will run enterpriseServer 2020.1-2902" E:\Program Files\burpsuite_enterprise\enterpriseServer>echo "running enterpriseServer" "running enterpriseServer" E:\Program Files\burpsuite_enterprise\enterpriseServer>IF "enterpriseServer" == "enterpriseServer" ( set MAIN_CLASS=net.portswigger.enterprise.server.StartEnterpriseServer set LOGBACK_FILE=server-logback.xml ) E:\Program Files\burpsuite_enterprise\enterpriseServer>IF "enterpriseServer" == "enterpriseAgent" ( set MAIN_CLASS=net.portswigger.enterprise.agent.StartAgent set LOGBACK_FILE=agent-logback.xml ) E:\Program Files\burpsuite_enterprise\enterpriseServer>IF "enterpriseServer" == "webServer" ( set MAIN_CLASS=net.portswigger.enterprise.web.StartWebServer set LOGBACK_FILE=web-logback.xml ) E:\Program Files\burpsuite_enterprise\enterpriseServer>set /p LOG_DIR= 0<.logDir E:\Program Files\burpsuite_enterprise\enterpriseServer>cd "2020.1-2902" E:\Program Files\burpsuite_enterprise\enterpriseServer\2020.1-2902>"E:\Program Files\burpsuite_enterprise\jres\9.0.4\bin\java" -cp lib\* -Dlogback.configurationFile=server-logback.xml -DlogsDirectory="E:\ProgramData\BurpSuiteEnterpriseEdition" net.portswigger.enterprise.server.StartEnterpriseServer child IO stream complete child IO stream complete Jan 31, 2020, 3:07:30 PM INFO: Supervisor child process completed with exit code 3 Jan 31, 2020, 3:07:30 PM INFO: Waiting for 4M16S before trying again...

Uthman, PortSwigger Agent | Last updated: Jan 31, 2020 02:21PM UTC

Hi Eduardo, What version were you updating from? How long did the update hang? Did your browser crash after? Can you access Enterprise at all right now? (i.e. can you reach the login window or is it not starting up at all?) Please send us an email on support@portswigger.net

Burp User | Last updated: Jan 31, 2020 02:49PM UTC

Hi, answers: What version were you updating from? From v1.1.03 as was shown on the updates portion. How long did the update hang? hanged for about 30 minutes at the "installing" phase on the web interface then it lost connection and now the page wont load. Did your browser crash after? Yes, it did after hanging. Can you access Enterprise at all right now? Cannot access Burpsuite as we do it via web. Cannot reach the login window

Burp User | Last updated: Feb 04, 2020 08:19PM UTC

- With the help of the support team we regained login access to Burpsuite. There was an issue with Burpsuite Site Name character lengths in which one was above 60 characters and was being truncated during the database migration on the update. - Make sure to have your site names below 60 characters.

Taylor | Last updated: Mar 02, 2020 10:05PM UTC

I ran into the exact issue. How can I check the length of our site names without accessing the web GUI? It's currently unavailable

Michelle, PortSwigger Agent | Last updated: Mar 03, 2020 09:40AM UTC

Hi Have you encountered this issue as you are upgrading to 2020.1 or upgrading from 2020.1 to 2020.2? Also, can you let us know what type of database you are using?

Sayon | Last updated: May 22, 2020 01:41PM UTC

I am updating to 2020.2 from 2020.1 and I am getting errors . The 2020.1 was working perfectly for me but when I downloaded the latest jar file(2020.2 ) and moved it /usr/bin directory and removed the earlier burpsuite file and named this to burpsuite but I can't open burp now .

Sayon | Last updated: May 22, 2020 01:41PM UTC

I am updating to 2020.2 from 2020.1 and I am getting errors . The 2020.1 was working perfectly for me but when I downloaded the latest jar file(2020.2 ) and moved it /usr/bin directory and removed the earlier burpsuite file and named this to burpsuite but I can't open burp now .

Sayon | Last updated: May 22, 2020 01:41PM UTC

I am updating to 2020.2 from 2020.1 and I am getting errors . The 2020.1 was working perfectly for me but when I downloaded the latest jar file(2020.2 ) and moved it /usr/bin directory and removed the earlier burpsuite file and named this to burpsuite but I can't open burp now .

Uthman, PortSwigger Agent | Last updated: May 22, 2020 02:33PM UTC

Hi, The update should be run from within the UI to avoid any issues. There is an updates section. Can you revert the change back and restart all the services? If you have any issues, please email us on support@portswigger.net with the latest log files and screenshots. You can find the log files at /var/log/BurpSuiteEnterpriseEdition on Mac/Linux and C:\ProgramData\BurpSuiteEnterpriseEdition on Windows.

You need to Log in to post a reply. Or register here, for free.