Burp Suite User Forum

Login to post

Issues installing Burp in Mac OS Catalina 10.15.4

Sergio | Last updated: Apr 22, 2020 09:04PM UTC

Hello, I am not able to install burp suite professional for a MAC with OS Catalina 10.15.4 I see the following message error when I tried to Install it: "Burp Suite Professional Installer" can't be opened because Apple cannot check it for malicious software. This software needs to be updated. Contact the developer for more information I tried to install burpsuite_pro_macos_v2020_2_1 Please let me know how to proceed. Thanks and regards, Sergio

Ben, PortSwigger Agent | Last updated: Apr 23, 2020 07:44AM UTC

Hi Sergio, This is due to the installer file not currently being notarized by PortSwigger and the security settings of the more recent versions of MacOS. We do have a feature request in our development backlog to resolve this issue in the future. In the meantime, the current workaround is to right click both the .dmg and .app files and then select Open in the resulting context menu. This will still bring up the warning dialog but there should now be an option to proceed with the installation.

Sundar | Last updated: Jun 16, 2020 08:10PM UTC

same issue in my laptop. ProductName: Mac OS X ProductVersion: 10.15.5 BuildVersion: 19F101

Ben, PortSwigger Agent | Last updated: Jun 17, 2020 08:01AM UTC

Hi, Have you tried the workaround suggested above?

Rachael | Last updated: Sep 04, 2020 02:37PM UTC

Hello, having the same issue, tried the work around, and it isn't working.

Ben, PortSwigger Agent | Last updated: Sep 07, 2020 09:06AM UTC

Hi Rachael, Unfortunately, if the security settings are hard coded (this might be likely if you are in a corporate environment) then the workaround is unlikely to work. Our developers are now, however, actively working on notarizing the macOS installer in order to resolve this issue. We will update this forum thread when we have some further news to share about this.

Uthman, PortSwigger Agent | Last updated: Oct 06, 2020 02:52PM UTC

We have now set up app notarization on the Mac installer. This means that you should no longer encounter the malicious software check error when running the installer. Please let us know if you have any issues with this in the future.

Turan | Last updated: Mar 29, 2021 06:46PM UTC

Having the same problem in MacOS 10.15.7 with Enterprise Edition 2021.3.1 and Enterprise Edition 2021.3.

Turan | Last updated: Mar 29, 2021 06:50PM UTC

Worked: downloaded the installer (Enterprise Edition 2021.3.1) from my PortSwigger account page instead of from https://portswigger.net/burp/releases#enterprise. Right-clicked and selected "open" on the .dmg and the installer .app and an option to proceed was presented.

Ben, PortSwigger Agent | Last updated: Mar 30, 2021 07:53AM UTC

Hi Turan,

Just to clarify - we have implemented notarization on the Burp Professional installer on Mac (the replies and responses in this forum post are related to Burp Professional). We are still working on this for the Burp Enterprise installer.

Your workaround is correct if you are having issues with the Burp Enterprise installer.

You need to Log in to post a reply. Or register here, for free.