Burp Suite User Forum

Login to post

Installion Error

Tayyip | Last updated: Aug 06, 2019 05:31AM UTC

In Static members: In action "Backup agent.config file [Run script]" (screen "Installation location"), property "Script": java.nio.file.InvalidPathException: Illegal char <:> at index 10: ${compiler:release.version} at java.base/sun.nio.fs.WindowsPathParser.normalize(WindowsPathParser.java:182) at java.base/sun.nio.fs.WindowsPathParser.parse(WindowsPathParser.java:153) at java.base/sun.nio.fs.WindowsPathParser.parse(WindowsPathParser.java:77) at java.base/sun.nio.fs.WindowsPath.parse(WindowsPath.java:92) at java.base/sun.nio.fs.WindowsFileSystem.getPath(WindowsFileSystem.java:229) at java.base/java.nio.file.Path.resolve(Path.java:402) at com.install4j.script.I4jScript_Internal_0.backupConfigFile(I4jScript_Internal_0.java:137) at com.install4j.script.I4jScript_Internal_182.eval(I4jScript_Internal_182.java:1) at com.install4j.script.I4jScript_Internal_182.evaluate(I4jScript_Internal_182.java:*24) at com.install4j.runtime.installer.helper.Script.evaluate(Script.java:33) at com.install4j.runtime.installer.ContextImpl.runScript(ContextImpl.java:202) at com.install4j.runtime.installer.ContextImpl.runScript(ContextImpl.java:196) at com.install4j.runtime.beans.actions.control.RunScriptAction.execute(RunScriptAction.java:34) at com.install4j.runtime.beans.actions.SystemInstallOrUninstallAction.install(SystemInstallOrUninstallAction.java:29) at com.install4j.runtime.installer.ContextImpl$9.executeAction(ContextImpl.java:1699) at com.install4j.runtime.installer.ContextImpl$9.fetchValue(ContextImpl.java:1690) at com.install4j.runtime.installer.ContextImpl$9.fetchValue(ContextImpl.java:1687) at com.install4j.runtime.installer.helper.comm.actions.FetchObjectAction.execute(FetchObjectAction.java:14) at com.install4j.runtime.installer.helper.comm.HelperCommunication.executeActionDirect(HelperCommunication.java:271) at com.install4j.runtime.installer.helper.comm.HelperCommunication.executeActionInt(HelperCommunication.java:246) at com.install4j.runtime.installer.helper.comm.HelperCommunication.executeActionChecked(HelperCommunication.java:184) at com.install4j.runtime.installer.helper.comm.HelperCommunication.fetchObjectChecked(HelperCommunication.java:167) at com.install4j.runtime.installer.ContextImpl.performActionIntStatic(ContextImpl.java:1687) at com.install4j.runtime.installer.InstallerContextImpl.performActionInt(InstallerContextImpl.java:159) at com.install4j.runtime.installer.ContextImpl.performAction(ContextImpl.java:1115) at com.install4j.runtime.installer.controller.Controller.executeAction(Controller.java:385) at com.install4j.runtime.installer.controller.Controller.executeActions(Controller.java:351) at com.install4j.runtime.installer.controller.Controller.executeActionGroup(Controller.java:422) at com.install4j.runtime.installer.controller.Controller.executeActions(Controller.java:356) at com.install4j.runtime.installer.controller.Controller.handleCommand(Controller.java:212) at com.install4j.runtime.installer.controller.Controller.start(Controller.java:111) at com.install4j.runtime.installer.Installer.runInProcess(Installer.java:58) at com.install4j.runtime.installer.Installer.main(Installer.java:45) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.base/java.lang.reflect.Method.invoke(Method.java:564) at com.exe4j.runtime.LauncherEngine.launch(LauncherEngine.java:85) at com.exe4j.runtime.WinLauncher.main(WinLauncher.java:94) at com.install4j.runtime.launcher.WinLauncher.main(WinLauncher.java:25) When i try Enterprise Edition Installing, end of the Install i get a error "Database Inistall has failed".How can i overcome this problem?

Liam, PortSwigger Agent | Last updated: Aug 06, 2019 09:20AM UTC

Thanks for this report. Which database are you using?

Burp User | Last updated: Aug 06, 2019 10:28AM UTC

I selected Embedded database.

Burp User | Last updated: Aug 06, 2019 11:42AM UTC

I have tried also other enterprise versions but I always get end of the inistillation "Database Inistall has failed".I have no use specific database(Default one which is Embedded database) .I updated my windows version but still I got facing with same problem.

PortSwigger Agent | Last updated: Aug 06, 2019 12:53PM UTC

Hi Tayyip, Are you installing over the top of an existing installation. If so could you uninstall and try again please. You can save any data in the previous installation by electing not to delete the data in the uninstaller, this can then be reused in your next installation. Let me know if you need any further assistance.

Burp User | Last updated: Aug 06, 2019 01:57PM UTC

I already uninstall more then 10 times and again install.When i uninstall i always get error those:Cant stop Agent,Web Server...(Somethings like that).And when Install i get end of the Install error"Failed to Initilize Database" i get this error from the start even in first time Install Burp Enterprise.

PortSwigger Agent | Last updated: Aug 06, 2019 02:48PM UTC

Sounds like there is a problem with the services on your machine. Could you open the services app on your machine and stop the burp suite enterprise services please. There are 4 services: Burp Suite Enterprise Edition Database, burpsuiteenterpriseedition_agent, burpsuiteenterpriseedition_enterpriseserver, burpsuiteenterpriseedition_webserver. Once these have stopped try to uninstall then install

Rose, PortSwigger Agent | Last updated: Aug 06, 2019 03:01PM UTC

We'd like to clarify something: Have you been able stop the services and then uninstall successfully using the provided uninstaller: C:/Program Files/burpsuite_enterprise/uninstall? We'd like to ensure you're managing to do this so that you're not just installing the new Burp Enterprise on top of the old one. You can save any data in the previous installation by electing not to delete the data in the uninstaller, this can then be reused in your next installation.

Burp User | Last updated: Aug 06, 2019 06:35PM UTC

There are only Burp Suite Enterprise Edition Database,burpsuiteenterpriseedition_enterpriseserver and i stopped them but i still got the same problems.

Burp User | Last updated: Aug 07, 2019 08:45AM UTC

I have notice that when burp creating a database folder there is a sql folder named "init" that is making a user on h2 Database but if i try login to h2 database with id and user which created from by "init" folder i cant login with those information so i have manueally added to h2 database than I got a error like "Failed to set up database initialization script".There must be problem about initializaiton on h2 database(Embedded),I have update my java,windows but problem still maintains.What need i do?

Burp User | Last updated: Aug 09, 2019 08:46AM UTC

You are looking first log and you say "you're not just installing the new Burp Enterprise on top of the old one" Okey i got it because i have tried so many times then i saw that log error and i deciaded to send Support probably i tried install burp without uninstall burp.But i have face with a problem "Database Inistall has failed" It's the error also i faced in first time of Install Burp Enterprise.There is a problem about Initilazing of database.It's have use Embedded Data base.I have tried login data base with properties of "init" sql file.There was nothing and i have executed commands of folder "init" in h2 and tried again i got error "Database inistializtion script has failed".I tried got database folder another pc and when Installing burp i replace them also i got "Database inistializtion script has failed".I created a Virtual Machine Linux Ubuntu and tried Install insade of that also i got "Database Inistall has failed".I deactivate All Security things(Firewall) maybe i though somethings blocking.But also i faced same problem.I dont know what can else I can do.Burp is not competely Installing so there is just Burp Suite Enterprise Edition Database,burpsuiteenterpriseedition_enterpriseserver servises and i stopping them before Unistall.(i have tried delete with logs without logs or whatever you can think ).I have never Install Burp even one time succesfully so there is no burp that can i Install top of It.I'm also sorry for disturbing and if i said somethings which is inappropriate .

Liam, PortSwigger Agent | Last updated: Aug 09, 2019 12:59PM UTC

Tayyip, could you do the following for us; Uninstall all Burp Enterprise files from your machine. Download a clean instance of Burp Enterprise and perform the standard installation again. Send screenshots of any error messages and the installation log files to support@portswigger.net. Thanks.

You need to Log in to post a reply. Or register here, for free.