Burp Suite User Forum

Create new post

I cannot install Autorize extension from BApp

pennywise01 | Last updated: Nov 01, 2022 02:31AM UTC

Hi currently I am enrolling in a API Security course. I am in a setup lab stage and it requires extension named Autorize. I already followed all the steps including put the stand along jython installer .jar file in python environment but I still can't install the extension. It said "Failed to load BApp". I am using Community Edition v2022.9.5, the jython installer version is jython-installer-2.7.3.jar. I also already did a health check and the result was all green. Please help me. Thank you. The error I am getting: java.lang.Exception: Failed to load Python interpreter from Jython JAR file at burp.mur.<init>(Unknown Source) at burp.mrz.p(Unknown Source) at burp.jnd.lambda$panelLoaded$0(Unknown Source) at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515) at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264) at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) at java.base/java.lang.Thread.run(Thread.java:829)

pennywise01 | Last updated: Nov 01, 2022 02:35AM UTC

NVM i sort it out

Liam, PortSwigger Agent | Last updated: Nov 01, 2022 06:38AM UTC

Thanks for letting us know, pennywise01.

Dhanraj | Last updated: Apr 18, 2023 05:51AM UTC

Hey @pennywise, can you please tell me how you solved this issue?

Liam, PortSwigger Agent | Last updated: Apr 19, 2023 06:51AM UTC

Hi Dhanraj, are you encountering the same issue? Do you see the same error message?

Dhanraj | Last updated: May 07, 2023 10:59AM UTC


Dominyque, PortSwigger Agent | Last updated: May 09, 2023 08:03AM UTC

Hi Dhanraj Can you please email us a screenshot of your Extension settings page at: support@portswigger.net

You must be an existing, logged-in customer to reply to a thread. Please email us for additional support.