Burp community forum

How to use Burp Proxy with an emulated android device?

Abe | Last updated: Jun 13, 2015 02:38AM UTC

Is it possible to route an emulated android device through Burp Proxy? I tried the instructions found here: https://support.portswigger.net/customer/portal/articles/1841101 But this says update the WIFI settings on the phone and when using an emulated device - WIFI is not available. Is there any way to route an emulated android device through burp proxy?

Liam, PortSwigger Agent | Last updated: Jun 16, 2015 08:56AM UTC

Hi Abe Thanks for your message. We’re going to investigate this issue and will get back to you within the next couple of days.

Liam, PortSwigger Agent | Last updated: Jun 16, 2015 09:17AM UTC

Hi Abe During our testing we found that not all emulators are able to proxy through Burp Suite. However, we have found various references that suggest that it is possible to route an emulated device through a proxy service. The steps below outline the method: Access the "Settings" menu on your emulated device. Go to or expand the "Wireless & Networks" section. Go to "Mobile/Cellular Networks". Go to "Access Point Names". Select the APN to edit the access point. In the "Edit access point" section, input the "proxy" and "port" you wish to proxy via. Good luck with your testing. Please let us know if you need any further assistance.

Burp User | Last updated: Jun 18, 2015 09:41PM UTC

Hrrm - so that is the one thing I had tried, but none of the traffic went through my proxy. Have you been able to do this using the method above?

Liam, PortSwigger Agent | Last updated: Jun 19, 2015 08:13AM UTC

Hi Abe We were unable to proxy the most recent version of the Android Emulator through Burp Suite. The emulator seems to be ignoring the proxy settings in the Access Point menu and connecting without a proxy. In addition, the emulator's browser repeatedly crashed when any attempt was made to access the Browser settings, regardless of how much memory we afforded to it. Please do let us know if you make any progress with this issue.

Burp User | Last updated: Jul 20, 2015 01:24PM UTC

Try starting on the command line like so C:\Users\dave\AppData\Local\Android\sdk\platform-tools>emulator -avd Nexus_5_API_22_x86 -no-audio -http-proxy 192.168.178.22::8082

Liam, PortSwigger Agent | Last updated: Jul 21, 2015 08:20AM UTC

Hi Dave Thanks for your message. Which version of Android Studio are you using?

Burp User | Last updated: Aug 28, 2015 11:30PM UTC

I still can't get apps to tunnel right over HTTPS ... it has worked in a fluke last night and today not working ... I was getting all HTTPS DNS going through burp .. not sure what changed ... is this still true ? http://forum.portswigger.net/post/497/thread This worked for me ....copy the cer to crt .. whatever .....and use the -http-proxy .. for hardware you can use proxydroid but for AVD you dont need to 1. Download cacert.der using your browser 2. Rename cacert.der to cacert.cer/cacert.crt 3. adb push cacert.cer /mnt/sdcard 3a. chmod 644 /mnt/sdcard/* 4. settings -> security -> install from SD card. emulator -avd 412 -qemu -nand system,size=0x1f400000,file=C:\Users\admin\.android\avd\412.avd\system.img -http-proxy 25.0.0.141:8080 on a side note a DAY ago I some how used FS CERT /BURP / PROXYDROID with a application and got ALL the HTTPS ... im not sure what the F#$^ happened but now its not working on phone and only in AVD ... I am close but I will be releasing a all in one portable Eclipse/android/ 4.1.2 ARM and 4.4.2 (Intels x86 uber fast HAXM) for some reason I still can't get some apps to work right "Proxydroid" for one ... 1/2 the time I run root apps they just crash ... everyything else works find ... trying to figure out build.prop to see if that will help ...I hate Java so much right now :) I mean more than most people ...

Burp User | Last updated: Aug 29, 2015 05:05AM UTC

UDPATE: I reset burp suite and wiped the data for proxydroid and it appears everything it working now only thing I put in was proxydroid IP and port and I left burp suite all reset to default and just put the listen on all interfaces in Burp. Also removed all certs and regenerated new cert to send to harddware phone and restarted burp. Thanks!

Burp User | Last updated: Aug 29, 2015 05:55AM UTC

I made a short video on the process: https://vimeo.com/137672482 In this video I go over how to setup Android with ProxyDroid and FS Cert Installer to push HTTPS App traffic to Burp Suite. Burp Suite Host: • Reset burp suite • Turn on listen to all interfaces Android Host: • Remove all User Certs • Stop task and remove data for ProxyDroid and FS Cert installer ( you can just uninstall reinstall ) • Put the phone in airplane mode then turn on WIFI • In FS Cert put in proxy IP and PORT then click the middle button Add CA and add it under WIFI Cert in the dropdown • Then click test chain and it should all be green yes for www.google.com • For Proxydroid just put in the IP and port and also tunnel DNS • Kill or reinstall any apps before you start to make sure they go through the proxy properly

Liam, PortSwigger Agent | Last updated: Sep 01, 2015 09:05AM UTC

Hi Robert We're glad you got everything working and thank you for providing the setup video.

Liam, PortSwigger Agent | Last updated: Sep 03, 2015 08:29AM UTC

Sikhuluwe, the video has been taken down, however, the steps should still work with pre-Nougat versions of Android. Please let us know if you need any further assistance.

Burp User | Last updated: Jan 03, 2018 05:39PM UTC

Hi rmccurdyDOTcom, I wanted to try the steps you outlined above but your vimeo link returns a 404. Do you still have it?

Burp User | Last updated: Aug 01, 2018 08:18AM UTC

May you please share the link for the video again.

Burp User | Last updated: Nov 14, 2018 03:08PM UTC

Hi Guys, Is it possible to set a upstream proxy servers with an android emulator? I've run my emulator with a command: emulator.exe -avd Test -http-proxy <proxy>:<port>. But now I do not know how to pass the trafic via burp in that approach.

Liam, PortSwigger Agent | Last updated: Nov 15, 2018 08:51AM UTC

Just to clarify, do you mean set the proxy within the emulator?

Burp User | Last updated: Nov 15, 2018 09:44AM UTC

My laptop has an access to Internet via proxy, so when I create android emulator to have the same access I must set the same proxy configuration on it. And now I want to listen to app requests/resonses via burp (so one proxy on burp to catch traffic and the second to the Internet).

Liam, PortSwigger Agent | Last updated: Nov 15, 2018 12:24PM UTC

Have you tried setting the proxy upstream of Burp using Burp's upstream proxy settings? - https://support.portswigger.net/customer/portal/articles/2363078-burp-suite-options-upstream-proxy-servers

You need to Log in to post a reply. Or register here, for free.