Burp community forum

how to start burp with specific extension loaded?

hong | Last updated: Dec 11, 2015 08:52PM UTC

Hi, I am doing burp automation test. I would like to know if there is a way to start burp with a specific extension loaded. I noticed that burp will start with the last configuration used. Is there a configuration file that we can specify which extension to load when burp starts? Thanks

Liam, PortSwigger Agent | Last updated: Dec 14, 2015 10:20AM UTC

Hi Hong Thanks for your message. It is not currently possible to start burp with a specific extension loaded. This is a feature we are working on, unfortunately we don't have an ETA. Please let us know if you need any further assistance.

Liam, PortSwigger Agent | Last updated: Feb 19, 2016 09:22AM UTC

Hi Gabriel Thanks for your message. You can accomplish this via command interface using a user-level config file. First, make a user config file containing your configured extensions. Then, specify on the command line to use that file. User settings can be specified on the command line using the —user-config-file option. Please let us know if you need any further assistance.

Burp User | Last updated: Mar 14, 2017 01:27PM UTC

Hello, I would like to start burp from the command line with an extension loaded (and also specified in the command line). Is it possible now? Thanks.

Burp User | Last updated: Mar 15, 2017 08:59AM UTC

Hi Liam, I am using the 1.703 free version of Burp. After I launch Burp from the command line, with the user-config file option, Burp starts but the greeting windows pops up (temp project, new project, opem existing project) so I have to click next..start burp...but the extension is not loaded. I did also a --config-file /path/configfile.json but I receive the following message only: Expected a value for option config-file My system is the following: Linux kali 4.8.0-kali2-amd64 #1 SMP Debian 4.8.11-1kali1 (2016-12-08) x86_64 GNU/Linux Any suggestion?

Liam, PortSwigger Agent | Last updated: Mar 15, 2017 09:07AM UTC

Hi Gabriel Try —user-config-file=

Burp User | Last updated: Mar 20, 2017 07:33AM UTC

It is not working. Burp starts, you have to click in the greeting windows, but the extension is not loaded. Do you have any other idea?

Liam, PortSwigger Agent | Last updated: Mar 20, 2017 09:36AM UTC

Sorry Gabriel, I may have made a typo in my last suggestion: --user-config-file=

Burp User | Last updated: Mar 20, 2017 11:07AM UTC

Well, i think that i used it in a correct way. However, it is not working. My goal is to run Burpsuite from command line with a loaded extension without any clicking (the extension works correctly). I tried this: burpsuite --user-config-file=/usr/share/javasnoop/extension/conf_file.json (I also tried -user-config-file=) Burp starts, the welcome window pops up, where I need to click <NEXT> for the temporary project. Then the configuration window pops up, where in the 'Load from the configuration file' window my conf file appears, but I still have to select it and click <NEXT>. Nevertheless, even then it is not working. Burp fails to load the extension and my proxy settings. So, do you have any idea?

Liam, PortSwigger Agent | Last updated: Mar 20, 2017 11:10AM UTC

Hi Gabriel We've just retested the process using the latest (.jar) version of Burp Suite and been able to load extensions from the command line using a user configuration file. When you load the configuration file using the 'Load from the configuration file' window, do your user configuration settings load as expected?

Liam, PortSwigger Agent | Last updated: Mar 20, 2017 12:24PM UTC

Hi Gabriel If you are unable to load the configuration file using the start-up wizard, it would seem that the file is the problem rather than your command line input. Have you tried creating a new config file? Which version of Burp are you using?

Burp User | Last updated: Mar 20, 2017 01:25PM UTC

Hi Liam, No. Unfortunately not. Could you please confirm that I used the correct commands for the configuration file loading? Is it possible to solve it by some configuration change or do I need to upgrade?

Liam, PortSwigger Agent | Last updated: Mar 20, 2017 01:38PM UTC

Non-UI-related options in individual Burp tools, such as Proxy and Scanner, can be loaded using Project configuration files: - https://portswigger.net/burp/help/suite_burp_projects.html You can load a project configuration file using the --config-file= command. Regarding starting Burp without using the start-up wizard, if you specify a project in your command line input, you won't have to click through the wizard. You can load a project file using the --project-file= command.

Burp User | Last updated: Mar 20, 2017 01:56PM UTC

I started Burpsuite from scratch, made a temporary project and I tried to load my config file. This worked partly, the extension loaded correctly but the proxy config, in the Proxy Listener window is completly blank. After it I tried it from the command line, the same happens as before. The greeting windows pop up, click next. Here I select again manually my config file and click next. It loads the same way as I described above, extension is OK but no Proxy Listener settings. However, I would like to avoid all the clicking and load everything properly from the command line..

Liam, PortSwigger Agent | Last updated: Mar 20, 2017 02:18PM UTC

Try updating your version of Burp Suite to the latest version (1.7.19). You can download the latest version of Burp Suite from your account page of our website.

Burp User | Last updated: Mar 20, 2017 02:47PM UTC

We are getting closer.. My version is 1.703. Following you explanation I can load the correct configuration file, without the wizzard amd trhe extension loads correctly. However, I am not able to specify the corresponding project file. I receive the following error: "Burp project files are not supported on this edition of Burp" Is it possible to overcome it?

Liam, PortSwigger Agent | Last updated: Mar 20, 2017 03:34PM UTC

Disk-based projects are only supported on Burp Suite Professional. You'll need the professional edition of Burp Suite to open from the command line without having to click through the wizard.

Burp User | Last updated: Mar 20, 2017 03:40PM UTC

I did an upgrade by apt-get. Now I have the 1.7.17 version. But I receive the same error message: "Burp project files are not supported on this edition of Burp"

Liam, PortSwigger Agent | Last updated: Mar 20, 2017 04:54PM UTC

Hi Gabriel A Burp project file should end in .burp. It looks like you are trying to load a configuration file as a project file. - https://portswigger.net/burp/help/suite_burp_projects.html

Burp User | Last updated: Mar 22, 2017 01:59PM UTC

Hi Liam, I did an upgrade to the trial pro-version 1.7.19. Everything seems to work correctly. I set up my enviroment and saved everything with the project and user options. However, with the following command line instruction: burpsuite --user-config-file=/usr/share/javasnoop/extensions/myextension/user_conf_19.json --project-file=/usr/share/javasnoop/extensions/myextension/project_conf_19.json I receive the following error message: Not a valid Burp project file: /usr/share/javasnoop/extensions/Replacer/project_conf_19.json Besides, I tried it also with: burpsuite --user-config-file=/usr/share/javasnoop/extensions/myextension/user_conf_19.json --config-file=/usr/share/javasnoop/extensions/myextension/project_conf_19.json Here, I do not receive any message just the wizzard window pops up...which I want to avoid.. My system is still the same as described above. Can you tell me what is wrong here?

Burp User | Last updated: Mar 22, 2017 03:02PM UTC

In the main Burp window, under Burp/Project options/Save project options the project is saved under .json file. The same applies for the User options. If I Save a state, the file has no extension. Based on the above and the command example copy/pasted can you tell how shoud I modify it? Or how should I load it correctly from the command line?

Liam, PortSwigger Agent | Last updated: Mar 22, 2017 03:04PM UTC

Burp project files hold all of the data and configuration for a particular piece of work. Data is saved incrementally into the file as you work. There is no need to specifically "save" your work when you are finished. When you use the Burp menu to save anything, you are not saving a Project file. You need to create a Burp Project file using the wizard, then you can use that file to open Burp from the command line.

Burp User | Last updated: Mar 22, 2017 03:22PM UTC

Now, it is crystal clear :) Thanks for the assistance.

Burp User | Last updated: Mar 27, 2019 01:05PM UTC

looks like you cant load profiles with free burp ( still waiting on req to go through for work :( ) path %PATH%;%CD%\FirefoxPortable\App\Firefox64\;%CD%\GoogleChromePortable\;%CD%\ZAP\;%CD%\java\;%CD%\java\bin\ set ROOTPATH=%CD% echo listing latest burp suite jar files for /f %%i in ('dir %CD%\*.jar /b/a-d/od/t:c') do set LAST=%%i echo starting latest burp suite # does not work for free # java -Xms2000m -Xmx2000m -XX:MaxPermSize=2000m -jar %LAST% --project-file=.\BURP_CONFIG\burp_project_config.json --user-config-file=.\BURP_CONFIG\burp_user_config.json java -Xms2000m -Xmx2000m -XX:MaxPermSize=2000m -jar %LAST% -------------- part of my portable burp free/zap setup bat script ;) loading pro plugins does not really work if it uses pro API calls. ------------- @echo off echo this includes: echo portable java 8 64bit echo python support in burp echo other plugins :) echo rmccurdy.com echo killing java and firefox taskkill /F /IM java.exe taskkill /F /IM javaw.exe taskkill /F /IM firefox.exe taskkill /F /IM chrome.exe taskkill /F /IM GoogleChromePortable.exe taskkill /F /IM iexplore.exe echo setting up config/bapp plugins ( this overwrites any and all settings in "%userprofile%\AppData\Roaming\BurpSuite" xcopy /q /y /s /i "%CD%\_BAPPS" "%userprofile%\AppData\Roaming\BurpSuite" >> %temp%\null copy /y "%CD%\_BAPPS\UserConfigPro.json" "%userprofile%\AppData\Roaming\BurpSuite\UserConfigCommunity.json" >> %temp%\null echo updateing setting path to firefox for cralwjax ( use ZAP INSTED if you have issues .... ) path %PATH%;%CD%\FirefoxPortable\App\Firefox64\;%CD%\GoogleChromePortable\;%CD%\ZAP\;%CD%\java\;%CD%\java\bin\ set ROOTPATH=%CD% echo flushing DNS cache ipconfig /flushdns echo setting up portable firefox proxy settings echo user_pref("network.proxy.ftp", "127.0.0.1"); > "%CD%\FirefoxPortable\Data\profile\prefs.js" echo user_pref("network.proxy.ftp_port", 8080); >>"%CD%\FirefoxPortable\Data\profile\prefs.js" echo user_pref("network.proxy.http", "127.0.0.1"); >>"%CD%\FirefoxPortable\Data\profile\prefs.js" echo user_pref("network.proxy.http_port", 8080); >>"%CD%\FirefoxPortable\Data\profile\prefs.js" echo user_pref("network.proxy.share_proxy_settings", true); >>"%CD%\FirefoxPortable\Data\profile\prefs.js" echo user_pref("network.proxy.socks", "127.0.0.1"); >>"%CD%\FirefoxPortable\Data\profile\prefs.js" echo user_pref("network.proxy.socks_port", 8080); >>"%CD%\FirefoxPortable\Data\profile\prefs.js" echo user_pref("network.proxy.ssl", "127.0.0.1"); >>"%CD%\FirefoxPortable\Data\profile\prefs.js" echo user_pref("network.proxy.ssl_port", 8080); >>"%CD%\FirefoxPortable\Data\profile\prefs.js" echo user_pref("network.proxy.type", 1); >>"%CD%\FirefoxPortable\Data\profile\prefs.js" echo starting portable firefox start cmd /c "%CD%\FirefoxPortable\FirefoxPortable.exe" echo starting portable chrome start cmd /c "%CD%\GoogleChromePortable\App\Chrome-bin\chrome.exe --proxy-server=localhost:8080" echo listing latest burp suite jar files for /f %%i in ('dir %CD%\*.jar /b/a-d/od/t:c') do set LAST=%%i echo starting latest burp suite start javaw -Xms2000m -Xmx2000m -XX:MaxPermSize=2000m -jar %LAST% echo overwrite ZAP folder content to the latest ZAP and setup on alternat port echo starting ZAP for /f %%i in ('dir %CD%\ZAP\*.jar /b/a-d/od/t:c') do set LAST=%%i echo starting ZAP cd %ROOTPATH%\ZAP\ start javaw -Xms2000m -Xmx2000m -XX:MaxPermSize=2000m -jar %LAST%

You need to Log in to post a reply. Or register here, for free.