Burp Suite User Forum

Login to post

How to change User-Agent send by Burp itself when connect via upstream proxy

Hsiang-Jen | Last updated: Oct 28, 2020 11:13AM UTC

When set upstream proxy server, burp will send the following request. (Not send by browser) Version 2020.9.2 ---begin--- CONNECT portswigger.net:443 HTTP/1.1 Host: portswigger.net:443 User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.121 Safari/537.36 ---end--- The User-Agent Chrome/85.0.4183.121 will be blocked by our proxy(Current 86 is allowed). This User-Agent send by Burp when connect via upstream proxy won't be replaced by "Match and Replace". (The User-Agent send by user browser will, but we will be blocked by proxy when CONNECT)

Michelle, PortSwigger Agent | Last updated: Oct 28, 2020 05:01PM UTC

Thanks for getting in touch. When you set up your scan, you can configure the User-Agent in the crawl configuration settings under Miscellaneous -> Customize User-Agent. We have also replied to your email so if you have any further questions, please let us know.

You need to Log in to post a reply. Or register here, for free.