Burp Suite User Forum

Login to post

Got strucked.. Cant know what to do

Sairam | Last updated: Oct 30, 2019 11:17AM UTC

Hello guys... I'm using burp suite for the first month it works perfectly later i stopped using this for a while due to my studies and extra works... Now when i'm using now it doesn't works as usual and it shows message: "The client failed to negotiate an SSL connection to www.XXXXXX.com:443: Received fatal error: decrypt_error" Since morning i'm searching the solution for this error and i didn't get any working one.. Please help me guys...

Ben, PortSwigger Agent | Last updated: Oct 31, 2019 08:03AM UTC

Hi, Thank you for your message. Is your Burp CA Certificate installed correctly in your browser? If this problem still persists, you might want to try to remove and then reinstall the certificate, the following link provides information on installing the certificate in your browser: https://support.portswigger.net/customer/portal/articles/1783075-installing-burp-s-ca-certificate-in-your-browser Please let us know if you need any further assistance.

Burp User | Last updated: Oct 31, 2019 09:07AM UTC

Hi, Mr.Ben Wright, Thanks for your response. I had tried what you had told, but the problem still continues. I think the problem is not with certificate, whenever i'm configuring browser proxy address than in burp suite it shows warning as " fatal error: decrypt_error". Please help me as soon as possible. I need burp suite for my project immediately.

Ben, PortSwigger Agent | Last updated: Oct 31, 2019 09:23AM UTC

Hi Sairam, Are you receiving this error on every site that you visit using Burp or is it just one site in particular? Would you be able to provide some more information about your environment setup (Burp version, browser that you are using, operating system your machine is running)?

Burp User | Last updated: Oct 31, 2019 11:42AM UTC

Hi Sir, As soon as I setup browser with proxy settings the burp suite warns with the error "The client failed to negotiate an SSL connection to www.XXXXXX.com:443: Received fatal error: decrypt_error" and then no site is going to work with proxy settings. When ever I turned off proxy again it works, but when the proxy is on no site works and shows "BAD_SIGNATURE" in browser and in burpsuite "The client failed to negotiate an SSL connection to www.XXXXXX.com:443: Received fatal error: decrypt_error" Burp suite version : 2.0.11beta.jar Browser : Google Chrome and Mozilla Firefox Operating System : Windows 10

Ben, PortSwigger Agent | Last updated: Oct 31, 2019 11:45AM UTC

Hi Sairam, Firstly, are you able to update your Burp version? The latest version is 2.1.04 and, as you are using a Beta, there may well be some issues in the version you are using. If you could update Burp and then see if this fixes the issue. If that does not work then you could try the following. If you go to Proxy -> Options -> Proxy Listeners and click the Regenerate CA certificate. Restart Burp and then remove your current Burp CA Certificate from within Firefox. If you can then download and install a fresh Burp CA Certificate in Firefox and see if that works. Please let us know if this resolves the issue.

Burp User | Last updated: Oct 31, 2019 02:57PM UTC

Hello Sir, Thank you so much... Finally problem solved, and it works perfectly now.

Ben, PortSwigger Agent | Last updated: Oct 31, 2019 02:59PM UTC

Hi Sairam, I am glad that we were able to resolve your issue. Please let us know if you need any further assistance with anything else in the future.

You need to Log in to post a reply. Or register here, for free.