Burp Suite User Forum

Freezes in scanner

Peter | Last updated: Jan 30, 2015 08:52AM UTC

Hi I've have problems running the scanner in 1.6.09, it's very unreliable. It just stopps scanning for no obvious reason, but it is a least not frozen. I can then save the state, kill Burp and reload the state. The scan will then continue for a few more URLs before freezing again. I have tried to set down the number of concurrent connections to just one, but it still just stops. The web site isn't frozen since it is nicely browsable in my browser. I can't figure out why this happens since it will get past the last point were it stopped after a complete re-load of Burp. It does however make testing very painful since I only get a few URLs scanned between every freeze. BR, Peter

Burp User | Last updated: Jan 31, 2015 12:02AM UTC

The above is what is happening when running on Windows 7 and Windows 8.1. I have this afternoon switched to Ubuntu 14.10 and now Burp runs without problems. /Peter

PortSwigger Agent | Last updated: Feb 02, 2015 11:25AM UTC

Sorry to hear about this problem. We aren't seeing this in our own testing. Is there some feature of the application that might explain why Burp's requests sometimes grind to a halt? Have you tried changing the timeout/retry values at Scanner / Options / Active Scanning Engine. In terms of troubleshooting, you could use the Custom Logger extension in the BApp Store to view a log of all requests made by Burp, so you can at least see which requests have been recently made at any time.

Burp User | Last updated: Sep 23, 2015 06:44PM UTC

I have noticed the same thing. I have fiddled with various settings with little results (memory, scan settings, etc). I have also tried some other items discussed in other threads. Once I moved to Kali I noticed a big difference. I notice that Kali 2 is using OpenJDK and not Oracle. The other difference is that I had some extensions. So I will add them one by one and see if the same behaviour occurs.

PortSwigger Agent | Last updated: Sep 24, 2015 08:24AM UTC

It would be worth trying the different Java vendor, yes. If you see problems with a particular extension, let us know which one and we'll investigate.

Burp User | Last updated: Jan 09, 2016 06:46PM UTC

I'm seeing exact the seem thing on Kali 2. It freezes regularly. It completely hangs when installing extensions. Does this have anything todo with openjdk and should I switch to Oracle? I'm using the latest version of burpsuite pro. It seems to be more unreliable the latest version.

Rose, PortSwigger Agent | Last updated: Feb 18, 2016 04:56PM UTC

Andy, when you say that Burp crashes, do you mean that it becomes unresponsive? Or is it just that the scanning task freezes? Could you send an email to support@portswigger.net with a screenshot of your Dashboard when the scanning freezes? Ensure all filters are switched on in the Event log and that all the Tasks are visible. I realise you said that you've tried everything listed above, but it was a bit ambigious as to whether it was suggested that you disable all installed Extensions. Could you just clarify on that one, please?

Burp User | Last updated: Sep 28, 2016 05:49PM UTC

I had this issue. After much debugging it turns out the problem was the extension J2EEScan. When that plugin was enabled it would freeze the entire scan at the same point every time. Great plugin. You can't cancel already running scans either....

Burp User | Last updated: Jul 20, 2018 11:06PM UTC

Hello, I'm still having this issue with version 1.7.35 on Windows 10. Was wondering if anyone has found a decent solution? I'm using no extentions, so the problem isn't specific to J2EEScan. I may be close by reducing timeouts and threads (concurrent request limit), but was curious if anyone had found some magic. Thanks!

Burp User | Last updated: Jul 11, 2019 03:17PM UTC

Hello, I'm still having this issue on Windows 10 with the new 2.1 Burp Suite release. To be clear, I was having it on 1.7.37 and upgraded in hopes it would be resolved (before this I was using it on Kali Linux and had the same issue). The scanner seems to get through passive scanning just fine but freezes on the first stage of active scanning. I can completely exit/restart and it will run for a few hundred requests before crashing again. Logger++ and Flow installed to troubleshoot, already followed the posted guides and tinkered with threads/timeouts. The site I'm scanning is not large at all (~20 pages) and the scanner runs up to 100,000+ requests to no avail. All informational/irrelevant checks and static analysis are disabled. I am using Firefox 68.0. Any help would be much appreciated. Burp support reps please note that if it has been listed above I've already tried it.

Liam, PortSwigger Agent | Last updated: Jul 15, 2019 12:42PM UTC

Chris, sorry for the delay in response. Would it be possible to send us your debug ID (support@portswigger.net)? Is the site you are testing publicly accessible?

Burp User | Last updated: Oct 08, 2019 05:41PM UTC

I am having the same problem as Andy with Burp Suite Pro 2. What is causing the scans to stop on the 1st active phase? This makes no sense and interferes with getting client work done. Thankfully I have other scanning tools that don't give me these problems.

You need to Log in to post a reply. Or register here, for free.