Burp Suite User Forum

Login to post

Forwarding requests not working

Breph | Last updated: Oct 15, 2019 09:34AM UTC

Hey folks, yesterday i noticed that i am not able to forward requests through the burp (it worked a month ago or so). I tried it in 2 Kali VMs and 1 ubuntu 1904. The proxy in firefox and burp are configured. The requests i send are intercepted but not forwarded - the Intercept tab stays empty but the browser is loading a long time until Burp return "Reply from SOCKS server has bad version". Screenshots i made: https://imgur.com/a/SdbaCqH Any tips how to fix this? Regards

Ben, PortSwigger Agent | Last updated: Oct 15, 2019 09:35AM UTC

Hi Breph, Thank you for your message. Do you have the SOCKS Proxy option enabled within User options -> Connections of the Burp instances that you are using? If so, can you disable this setting by unchecking the Use SOCKS proxy option and then seeing if the intercepting and forwarding of requests now works as expected.

Ben, PortSwigger Agent | Last updated: Oct 15, 2019 10:09AM UTC

Hi Breph, Not a problem. Glad you were able to get it sorted out in the end.

Burp User | Last updated: Oct 15, 2019 10:30AM UTC

Hey Ben Wright, oof.. what a stupid mistake. It was checked and it works now after i disabled it. Thank you very much! Best regards :)

mark | Last updated: Jul 04, 2020 08:26PM UTC

Hi guys I've got the same problem however mine isn't checked....?

mark | Last updated: Jul 04, 2020 08:27PM UTC

no matter what i try i cannot get anything to work

Hannah, PortSwigger Agent | Last updated: Jul 06, 2020 10:37AM UTC

Hi Mark Could you provide us with a description of your issue, please? Could you also tell me which version of Burp Suite you are using, whether you are using the platform version or the standalone JAR file, and the OS that you are operating on?

You need to Log in to post a reply. Or register here, for free.