Burp Suite User Forum

Login to post

Font issue - CJK characters are not rendered correctly

Jackpot | Last updated: Apr 25, 2021 07:50AM UTC

After googling, change the font to "DialogInput" (13pt) in User Options -> Display -> HTTP Message Display seems to fix this, partially. After changing the font, since there are many websites which do not use UTF-8 (eg. http://www.gov.cn ), some characters still can't be rendered correctly. To fix this, character encodings like GBK, SHIFT-JIS etc should also be supported, then the user should alse be able to manually switch among different encodings.

Jackpot | Last updated: Apr 25, 2021 07:53AM UTC

Oh sorry, www.gov.cn is using UTF-8. It was just the title showed in HTTP history which was incorrectly rendered. This should be caused by erroneously treating UTF-8 Chinese characters as ISO8859-1.

Uthman, PortSwigger Agent | Last updated: Apr 27, 2021 01:24PM UTC

Have you looked at the character sets available under User options > Display > Character Sets? Can you try setting it to UTF-8 or display as raw bytes?

Jackpot | Last updated: Apr 28, 2021 07:31AM UTC

>the character sets available under User options > Display > Character Sets Tried changing this to UTF-8. Still didn't fix the incorrectly decoded characters in the "Title" column of "HTTP history". It was not "tofu", but something like "由月è|å¥½å¥½å-|ä1 天天向上" (not that this is not from www.gov.cn ), which should be caused by errnenously decoding UTF-8 Chinese characters as ISO8859-1. Request/response content is in a different situation: changing font to "DialogInput" does fix the "tofu" Chinese characters there.

Uthman, PortSwigger Agent | Last updated: Apr 29, 2021 08:33AM UTC

Thanks. The 'Title' column is likely an issue of Burp not handling multibyte characters well. We will let you know when support for that is added to Burp.

You need to Log in to post a reply. Or register here, for free.