Burp Suite User Forum

Login to post

Fix ERR_UNSAFE_PORT error on built-in browser

Nelson | Last updated: Jun 22, 2021 10:02PM UTC

I'm trying to access a service listening on port 10080 and the built-in Chromium browser is returning an error: ERR_UNSAFE_PORT On "regular" Chromium I can use the explicitly-allowed-ports parameter to bypass this, but how can I do that with the built-in browser? I tried starting it manually with the flag, but then it doesn't use Burp as a proxy.

Michelle, PortSwigger Agent | Last updated: Jun 23, 2021 09:35AM UTC

Thanks for your message. I'm afraid it's not currently possible to use the explicitly-allowed-ports parameter with the built-in browser. Are you looking to run an automated scan of this site or are you more interested in testing the site manually?

Michelle, PortSwigger Agent | Last updated: Jun 24, 2021 07:22AM UTC

Would having a device between Pro and the application you are scanning to perform translation on the port, so Burp could use a different port, be an option that would work in your scenario?

Nelson | Last updated: Jun 24, 2021 03:01PM UTC

I'll just use Firefox for now. Thanks!

Jack | Last updated: Mar 09, 2023 11:41AM UTC

I have fixed my problem by changing the Target of the Chrome shortcut. https://thegeekpage.com/err-unsafe-port/

You need to Log in to post a reply. Or register here, for free.