Burp Suite User Forum

Login to post

firefox error

Carl | Last updated: Jan 07, 2022 04:16AM UTC

I have followed the instructions letter by letter. inserted the certificate so fire fox would trust it. I have gone to burger menu/preferences/network/settings/ manually configure proxy with my loop back of 127.0.0.1 on port 8080 and when i save the settings. I then try to access a website and it says my proxy configurations are The proxy server is refusing connections "Firefox is configured to use a proxy server that is refusing connections. Check the proxy settings to make sure that they are correct. Contact your network administrator to make sure the proxy server is working." I dont get it. Do i have to change my preferences every time I want to use burp? because burp works when I open it and change the firefox settings. I have set up burp a few times now. I have even had the ext foxy-proxy which was sweet. But now all i want to do is just be able to surf the internet and use burp when it is open and I have intercept on etc. Please help me

Ben, PortSwigger Agent | Last updated: Jan 07, 2022 09:02AM UTC

Hi Carl, Just to confirm, you would need to alter your browser proxy settings each time you want to use Burp. If you have proxy settings configured within your browser and Burp is not running then you are going to hit this issue because the browser is trying to send the traffic to the Burp Proxy Listener, which will not be running at that point in time. Some people use tools like FoxyProxy to make switching these settings on and off easier to manage (essentially you can switch your proxy settings off with a couple of clicks rather than having to go into the settings directly). Alternatively, you could use the embedded browser that comes with Burp itself which is preconfigured to proxy traffic through Burp without you having to make any changes (this is available via Proxy -> Intercept -> Open Browser).

You need to Log in to post a reply. Or register here, for free.