Burp Suite User Forum

Login to post

Failed to start proxy service on 127.0.0.1:<ANY PORT>

Gabriel | Last updated: Jun 14, 2022 10:33PM UTC

Hi, I am having an issue where Burpsuite will not bind to any port on localhost e.g. 127.0.0.1:8080,9999 etc. OS: Windows 10 Browser: Firefox Error message: 'Error "Failed to start proxy server on 127.0.0.01:<ANY PORT NUMBER> Check whether another service is already using this port' I have tried the following: - Ensured my browser was configured to the appropriate address(es) and port(s) and verified that intercept was on in burp. - Tried removing and importing the Burpsuite digital certificate, along with regenerating the certificate and repeating the steps. - Ensured that no local services were conflicting with the port numbers I set in burp (via netstat -ab). - Tried running Burpsuite in both the user and administrator contexts. - I have even tried whitelisting port 8080 in about:config (network.security.ports.banned.override) I have tried looking for clues in the diagnostics and debug logs, but there was nothing I could see which was related to this issue, although I am happy to provide logs if it would help diagnose this issue. As far as I can tell, the issue is with Burpsuite itself as opposed to the Browser or foxy proxy utility. I did notice another setting in Firefox's configuration which could potentially be the culprit, but I am unsure (The setting titled network.proxy.no_proxies_on with values of localhost, 127.0.0.1). Thank you in advance, Gabriel

Hannah, PortSwigger Agent | Last updated: Jun 15, 2022 09:03AM UTC

Hi Just to verify, this error message is appearing in your "Dashboard > Event log" within Burp? Was there any difference in your error message when using an administrator context? Does Burp's browser function correctly? You can access it by going to "Proxy > Intercept > Open browser". Are you currently using the Installer version of Burp? If you try using the standalone JAR file, do you see any difference? You can find the latest version of Burp here: https://portswigger.net/burp/releases#professional You can find instructions for launching Burp from the command line here: https://portswigger.net/burp/documentation/desktop/getting-started/launch-from-command-line

Gabriel | Last updated: Jun 18, 2022 09:33PM UTC

Hi Hannah, The error message appears in Proxy > Options, when I try to enable the listener in 'proxy interface', the error message is returned. It seems to be disabled by default for some reason. There were no noticeable difference in the error message between user contexts. Burps built-in browser does work, however I did notice that a few of the application I was targeting blocked me when using it. I would prefer not to use the Standalone JAR if possible, similarly to the integrated browser. If I can provide anything else to help diagnose the issue please let me know. Kind regards Gabriel

Hannah, PortSwigger Agent | Last updated: Jun 20, 2022 01:47PM UTC

Hi Do you have any antivirus or other security measures present on your machine, that might stop Burp from binding to a port? If you reinstall the latest installer version of Burp, does the issue persist?

Gabriel | Last updated: Jun 23, 2022 09:01PM UTC

Hi Hannah, I do have an antivirus product but I have whitelisted Burp within its network security settings. The product forums understandably does not document how to configure it to work with Burp however, as it is an admittedly niche issue. I did try reinstalling with the pro installer, unfortunately the problem persists. I could try completely uninstalling it from the system entirely then running the installer again as a last resort, however I am not too keen on using up my activation attempts, which is part of the reason I am using it in on my host and not within a virtual machine. I understand if the assistance that can be provided going forward is limited and I appreciate the support I have received up until now.

Hannah, PortSwigger Agent | Last updated: Jun 24, 2022 09:04AM UTC

If you need any additional activations, we are able to provide you with them. You could try running Burp in a virtual machine - you shouldn't have an issue with activations, provided you don't revert your VM to a state prior to activation. Alternatively, you could try temporarily disabling your antivirus software, and see if that sorts out the port binding issue. This would help verify that it is the antivirus software causing the issue.

Jirafita | Last updated: Nov 23, 2022 01:53PM UTC

Hi there, I'm experimenting the same issue since a while. - I have no anti-virus - Firewall is disabled - I would rather not use the standalone option - I need to use firefox, not the embed browser - I tried reinstalling - I tried removing Burp completely and installing again - I tried updating (currently using the last version, but this problem has occurred with older versions) I would really appreciate if you could provide so further assistance, the only thing that seems to fix this is restarting Windows, however, this is not a good option as I have to close every single program and it impacts on my daily work. Thanks

Hannah, PortSwigger Agent | Last updated: Nov 24, 2022 10:54AM UTC

Hi Could you drop us an email at support@portswigger.net with your diagnostics information? You can find this by going to "Help > Diagnostics" within Burp.

You need to Log in to post a reply. Or register here, for free.