Burp Suite User Forum

Login to post

Failed to load Python interpreter from Jython JAR file

Shubham | Last updated: Aug 12, 2019 07:43PM UTC

Hello Dear, I am facing an error. I am not able to add my extension in Burp. I am getting the follow error: java.lang.Exception: Failed to load Python interpreter from Jython JAR file at burp.a3t.<init>(Unknown Source) at burp.gcg.a(Unknown Source) at burp.ao3.lambda$panelLoaded$0(Unknown Source) at java.lang.Thread.run(Unknown Source) Please help me out. Thank's and Regards, Shubham

Liam, PortSwigger Agent | Last updated: Aug 14, 2019 10:14AM UTC

This error is usually caused by using a corrupt or incorrect Jython jar. Please download again from this URL and re-configure: - http://search.maven.org/remotecontent?filepath=org/python/jython-standalone/2.7.0/jython-standalone-2.7.0.jar Please let us know if you need any further assistance.

Ramiro | Last updated: Jul 09, 2021 04:39AM UTC

Thanks, very useful answer.

Jay | Last updated: Apr 07, 2023 09:13AM UTC

java.lang.Exception: Failed to load Python interpreter from Jython JAR file at burp.juj.R(Unknown Source) at burp.b4r.L(Unknown Source) at burp.tn1.N(Unknown Source) at burp.c_l.lambda$panelLoaded$0(Unknown Source) at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:577) at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:317) at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1144) at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:642) at java.base/java.lang.Thread.run(Thread.java:1589) i got this error what should i do

Ben, PortSwigger Agent | Last updated: Apr 07, 2023 09:27AM UTC

Hi Jay, Are you able to provide us with some screenshots of exactly what you are doing when you see this error?

Nikhil | Last updated: May 23, 2023 12:43PM UTC

java.lang.Exception: Failed to load Python interpreter from Jython JAR file at burp.Zsxg.Zw(Unknown Source) at burp.Zn33.ZU(Unknown Source) at burp.Zlx.ZN(Unknown Source) at burp.Ztdm.lambda$panelLoaded$0(Unknown Source) at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:539) at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264) at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1136) at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:635) at java.base/java.lang.Thread.run(Thread.java:833) Got error while installing 403 Bypasser...!!! where i can share you the screenshot??

Michelle, PortSwigger Agent | Last updated: May 23, 2023 01:02PM UTC

Hi Can you please send the screenshot to support@portswigger.net. Can you also confirm which version of the Jython JAR file and which version of Burp you are using?

Thomas | Last updated: Jul 14, 2023 11:46AM UTC

I had the same problem, so I updated my Jython to the newest Version 2.7.3 and then it worked just fine.

coder | Last updated: Sep 08, 2023 06:18PM UTC

Am also faced the same problem. Use the older version of jython:2.7.2 worked fine for me. https://repo1.maven.org/maven2/org/python/jython-standalone/2.7.2/jython-standalone-2.7.2.jar

You need to Log in to post a reply. Or register here, for free.