Burp Suite User Forum

Login to post

Failed to connect to sitename.net:443 - Only AWS Sites

cleon | Last updated: May 26, 2022 07:44PM UTC

I'm running the latest version of Burp Pro and FireFox. I have the certificate installed correctly. I'm not going through a corporate proxy when I test. Just figured I'd get that info out of the way now. We are migrating some of our web apps to AWS and I need to pen test them. Ever since we moved them to AWS, 90% of the time when I try to proxy FireFox through Burp, I'm not able to connect to the sites. Sometimes they'll randomly start to work through Burp, but then will stop shortly after. The event log just shows "Failed to connect to sitename.net:443. There are six of them that all give me the same issue. If I stop feeding FireFox through Burp, sites work fine, I force them through Burp, and immediately they stop working. Is there something in AWS that would prevent Burp from working? I'm only having issues with these particular sites. All other sites that are on prem work fine.

Liam, PortSwigger Agent | Last updated: May 27, 2022 12:46PM UTC

Thanks for your message. Does this issue only occur on Firefox? What happens if you use the embedded Burp browser? Which version of Firefox are you using?

cleon | Last updated: May 31, 2022 03:03PM UTC

The issue happens in the embedded Burp browser as well. FireFox version 101.0

Liam, PortSwigger Agent | Last updated: Jun 01, 2022 05:47AM UTC

Are the sites public facing? If so, is it possible to share the details? You can email us via support@portswigger.net.

You need to Log in to post a reply. Or register here, for free.