Burp Suite User Forum

Create new post

Failed to configure embedded browser

Robert | Last updated: Mar 03, 2020 03:38AM UTC

Installation on Windows 10 machine. I get the error message "Failed to configure the embedded browser" when running the installation for Burp Pro

Robert | Last updated: Mar 03, 2020 03:41AM UTC

Right clicking and selecting run as administrator worked to install 2020.2. It would be nice if that information was in the instructions, or if the installer took advantage of UAC.

Uthman, PortSwigger Agent | Last updated: Mar 03, 2020 09:33AM UTC

Hi Robert, We are looking into providing a fix for this.

Uthman, PortSwigger Agent | Last updated: Mar 03, 2020 12:15PM UTC

Hi Robert, The installer has now been fixed. Any further downloads should install as normal.

Julian | Last updated: Mar 23, 2021 07:42AM UTC

The problem remains on Linux (doing upgrade as a regular user, as doing it as root would require re-activation and is not what I want, I have been successfully upgrading as regular user the installation in its home directory up until this point).

Uthman, PortSwigger Agent | Last updated: Mar 23, 2021 01:11PM UTC

Julian, can you please email support@portswigger.net with further information and a screen recording of your issue?

david | Last updated: Mar 22, 2022 11:43AM UTC

If you are installing in windows 10 , you can solve the error by turning of your antivirus and then run as an admin @robert

Samuel | Last updated: Aug 28, 2023 08:04AM UTC

Im experiencing the same issue on kali Linux, Burp Suite Professional ran an auto update and upon restarting Burp it opened an error dialogue saying "Failed to configure embedded browser." I then downloaded the latest .sh installer file (2023_9_3) and attempted to update my installation, the installer fails with the same error and burp suite doesn't run

Dominyque, PortSwigger Agent | Last updated: Aug 28, 2023 09:10AM UTC

Hi Samuel Can you please provide us with the MD5 checksum of the Installer file that you have downloaded?

Samuel | Last updated: Aug 29, 2023 12:29AM UTC

MD5: 5154343371cde175e88d102db9aaf779 burpsuite_pro_linux_v2023_9_3.sh EDIT: I fixed the issue by performing an uninstall (using the standard burp uninstall script), And then re-installed using the above installer and it came good..

You must be an existing, logged-in customer to reply to a thread. Please email us for additional support.