Burp Suite User Forum

Login to post

Extensions Load Error

ibrahim | Last updated: Nov 20, 2020 11:38AM UTC

hello, While installing java or ruby related plugins, plugins with python do not load and give an error message. The plugin I wrote and the plugin I tried to download from the bapp store is not installed. jruby version : 9.2.13.0 jython version : 2.7.2 JDK version : 15.0.1 Java(TM) SE Runtime Environment (build 15.0.1+9-18) java 15.0.1 2020-10-20 Java HotSpot(TM) 64-Bit Server VM (build 15.0.1+9-18, mixed mode, sharing) Error Message : java.lang.ExceptionInInitializerError at org.python.util.PythonInterpreter.<init>(PythonInterpreter.java:99) at org.python.util.PythonInterpreter.<init>(PythonInterpreter.java:93) at org.python.util.PythonInterpreter.<init>(PythonInterpreter.java:70) at java.base/jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) at java.base/jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) at java.base/jdk.internal.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) at java.base/java.lang.reflect.Constructor.newInstanceWithCaller(Constructor.java:500) at java.base/java.lang.reflect.Constructor.newInstance(Constructor.java:481) at burp.c2p.<init>(Unknown Source) at burp.cvi.a(Unknown Source) at burp.cl1.lambda$panelLoaded$0(Unknown Source) at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515) at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264) at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) at java.base/java.lang.Thread.run(Thread.java:835) Caused by: java.lang.IllegalArgumentException: Cannot create PyString with non-byte value at org.python.core.PyString.<init>(PyString.java:57) at org.python.core.PyString.<init>(PyString.java:70) at org.python.core.PyString.<init>(PyString.java:74) at org.python.core.Py.newString(Py.java:643) at org.python.core.PyJavaType.init(PyJavaType.java:543) at org.python.core.PyType$Registry.createType(PyType.java:477) at org.python.core.PyType$Registry.addFromClass(PyType.java:426) at org.python.core.PyType$Registry.resolveType(PyType.java:352) at org.python.core.PyType$Registry$1.computeValue(PyType.java:208) at org.python.core.PyType$Registry$1.computeValue(PyType.java:202) at java.base/java.lang.ClassValue.getFromHashMap(ClassValue.java:226) at java.base/java.lang.ClassValue.getFromBackup(ClassValue.java:208) at java.base/java.lang.ClassValue.get(ClassValue.java:114) at org.python.core.PyType.fromClass(PyType.java:2137) at org.python.core.PyObject.<init>(PyObject.java:85) at org.python.core.PySingleton.<init>(PySingleton.java:9) at org.python.core.PyNotImplemented.<init>(PyNotImplemented.java:10) at org.python.core.Py.<clinit>(Py.java:66) ... 16 more

Uthman, PortSwigger Agent | Last updated: Nov 20, 2020 12:04PM UTC

Which version of Burp are you using? Is the output attached the errors from your own extension or another one? Can you try using OpenJDK 14.0.2+12 to launch Burp or use the platform version? e.g. .exe

ibrahim | Last updated: Nov 20, 2020 03:46PM UTC

I get errors on both, both when I write and download it from the store. For example authmatrix. I using Burp v2020.1 Build 1297. I tried, but the result is the same, I still get an error.

Uthman, PortSwigger Agent | Last updated: Nov 20, 2020 03:54PM UTC

Thanks. 2020.1 was released before OpenJDK 15. Can you try the latest platform build? The correct JRE is embedded in it.

ibrahim | Last updated: Nov 21, 2020 07:43AM UTC

ı was update burpsuite 2020.11.1 and JDK 15.0.1 but problem same. Most current versions currently. :/

Uthman, PortSwigger Agent | Last updated: Nov 23, 2020 09:41AM UTC

I just tested Auth Matrix and I have no issues with that. It looks like you are still using Java 15. Please try using OpenJDK 14.0.2 (https://jdk.java.net/archive/). If you can send us an email with screenshots, that would be great too - support@portswigger.net

You need to Log in to post a reply. Or register here, for free.