Burp Suite User Forum

Login to post

Extension not working after Burp update

Stephan | Last updated: Apr 11, 2023 06:09AM UTC

Hi! I switched over to the Montoya API and my extension implements BurpExtension. In the last versions of Burp, I did not notice any issues. But after updating to the current version, the extension does not load anymore with the following error: java.lang.Exception: Extension class is not a recognized type at burp.Zd5v.Zu(Unknown Source) at burp.Zd5v.Zy(Unknown Source) at burp.Zz5_.ZQ(Unknown Source) at burp.Zjva.ZY(Unknown Source) at burp.Zjrv.lambda$panelLoaded$0(Unknown Source) at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:577) at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:317) at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1144) at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:642) at java.base/java.lang.Thread.run(Thread.java:1589) Does anybody have an idea how to fix this? Thanks!

Hannah, PortSwigger Agent | Last updated: Apr 11, 2023 08:41AM UTC

Hi Could you tell me the version of the Montoya API you are using and the version of Burp that is being used?

Stephan | Last updated: Apr 12, 2023 04:39AM UTC

I included the following with Burp v2023.3.2: api 'net.portswigger.burp.extender:burp-extender-api:2.1' api 'net.portswigger.burp.extensions:montoya-api:2023.4'

Hannah, PortSwigger Agent | Last updated: Apr 12, 2023 08:40AM UTC

Hi The version number of the Montoya API represents the minimum version of Burp that the API is compatible with. Can you downgrade the Montoya API version to 2023.3 to match your Burp version? v2023.4 of Burp will be released on Early Adopter soon.

Stephan | Last updated: Apr 12, 2023 12:43PM UTC

I downgraded to Montoya API 2023.3. However, I still get the same error as above ("Extension class is not a recognized type").

Hannah, PortSwigger Agent | Last updated: Apr 13, 2023 03:02PM UTC

Could you please drop us an email at support@portswigger.net with a copy of your project so we can try and replicate your issue? It would also be helpful if you could include a copy of your diagnostics. You can find this by going to "Help > Diagnostics" within Burp.

Stephan | Last updated: Apr 25, 2023 12:18PM UTC

Fixed: There was an issue with my gradle.build file.

You need to Log in to post a reply. Or register here, for free.