Burp Suite User Forum

Login to post

Extension does not load when BURP is loaded through Windows Task Scheduler while not logged in

Michael | Last updated: Apr 04, 2018 05:59PM UTC

I'm trying to run BURP with my extension with the Windows's Task Scheduler. When I'm logged in, the Task Scheduler is able to open BURP in headless mode and preload my python extension fine. The issue is when I'm not logged into the Windows. I written an command line output to txt file so I see BURP was successfully opened, but I don't see my see outputs from my extension. I am currently running Windows 10. Are you guys aware of a solution that allows BURP and extension to run while not logged in?

PortSwigger Agent | Last updated: Apr 05, 2018 07:04AM UTC

Hi Michael, Thanks for your message. I just tried this and my extension started correctly for me. Can you provide some more details on how you've configured your scheduled task? In particular, how you are making Burp start headlessly. If you start Burp in headed mode, it will prompt you to open a project file, and extensions are not loaded until this dialog has been closed. I started Burp like this: "c:\Program Files\BurpSuitePro\jre\bin\java.exe" -Djava.awt.headless=true -jar "c:\Program Files\BurpSuitePro\burpsuite_pro.jar" Please let us know if you need any further assistance.

Burp User | Last updated: Apr 05, 2018 06:31PM UTC

I have a similar line where "-Djava.awt.headless=true" is in it except I have --project-file parameter. In the Task Scheduler, I selected "Run whether user is logged on or not" with the "Do not store password." checkbox unchecked. I also have "Run with highest privileges" checked. Just to make sure we're on the same page, I was logged off of the workstation when the schedule runs the task. After it has started running, I log back in to check. So you're saying in that scenario you were able to tell the python extension loaded? BURP and my extension is able to runs fine in the background if the schedule task starts while I'm logged in. The problem is when I'm not logged in and computer is still on.

PortSwigger Agent | Last updated: Apr 06, 2018 07:19AM UTC

Hi Michael, Thanks for following up. I've just tested this quite thoroughly and it definitely is working for me, in exactly the setup you describe - including when I'm not logged in. A few things that could be going on: 1) Perhaps Burp is not terminating, so the subsequent tasks don't run? (In testing I was manually ending tasks) 2) Are you using the same user to scheduled task and interactive use? The extension settings are per-user. 3) When I first tried to set this up my account didn't have permission to execute batch jobs (can't remember exact wording) - so I had to use administrator account instead. Please let us know if you need any further assistance.

Burp User | Last updated: Nov 14, 2018 12:49AM UTC

Hi there, Can you please provide/redirect me how to use the task scheduler to open and run the BURP scan. From above comment, I see we need to use the following command in the “c:\Program Files\BurpSuitePro\jre\bin\java.exe” -Djava.awt.headless=true -jar “c:\Program Files\BurpSuitePro\burpsuite_pro.jar” Seems like I am missing the project here. Here how can I give the required project. How can I know if the task is running or not. Also please suggest on how to view the reports. Thanks, Tejo.

PortSwigger Agent | Last updated: Nov 16, 2018 01:47PM UTC

Tejo - Task Scheduler doesn't have that capability. With Burp 1 you need to use an extension like Carbonator. With Burp 2 you need to use the REST API.

Bhaskar | Last updated: Jun 09, 2020 10:52AM UTC

I am continuously facing this issue. I'm using burp pro on mac and every time i open burp i have to load all the extensions manually. Is this known issue or any fix for this?

Hannah, PortSwigger Agent | Last updated: Jun 09, 2020 11:33AM UTC

Hi Bhaskar This issue does seem to pop up from time to time. Unfortunately, we've never been able to replicate it. Could you tell me the version of Burp you are using, whether you are using the standalone or platform version, and if you are closing Burp properly or forcing a close? Are your extensions being completely removed, or just unloaded?

You need to Log in to post a reply. Or register here, for free.