Burp Suite User Forum

Login to post

Errors: Request Timeout

Hardik | Last updated: Jun 24, 2020 06:46PM UTC

While scanning I am getting Communication error in event log. When I went to details of my scan some requests were having status Errors: Request Timeout. When I send that request to repeater I am getting 200 response. At the end of my scan, even if I am getting the issues of my app, the scan status for all the urls is Errors: Request Timeout instead of Done. Can you comment.

Michelle, PortSwigger Agent | Last updated: Jun 25, 2020 01:29PM UTC

There can be many different reasons for a request timing out. Can you tell us a bit more about your scan, please? Are you manually crawling the site or are you doing the Crawl as part of your scan? If you are using Burp professional and throttle the requests by changing the resource pool settings for the scan, do you see the same issues? What version of Burp are you using?

Hardik | Last updated: Jun 26, 2020 07:02AM UTC

I am doing crawl as part of my scan.(choosing Audit selected items) I am using version 2020.5 pro Yes by changing the resource pool settings for the scan,by changing the resource pool settings for the scan, I see the same issues.(Maximum concurrent requests:20, and dealy:1 sec) Moreover the same request is getting this error but when I send it to repeater it gives the 200 status.

Hardik | Last updated: Jun 26, 2020 07:08AM UTC

In logger++ i havent found 408 status(timeout) corresponding to any request.

Michelle, PortSwigger Agent | Last updated: Jun 26, 2020 07:50AM UTC

There can sometimes be network protections in place that can mean some requests will time out when an application sees a large number of requests from the same machine. Could you try reducing the resource pool to use 'Maximum Concurrent Requests' of 5 or lower and let me know if this helps, please?

Hardik | Last updated: Jun 26, 2020 08:28AM UTC

Still facing same having max concurrent req as 2

Michelle, PortSwigger Agent | Last updated: Jun 29, 2020 09:58AM UTC

Would you be happy to share some more details of the scan with us via email? If so, could you send the following to support@portswigger.net so we can take a closer look, please? - Screenshots of the Scan settings being used - Screenshots of the different tabs in the scan task

You need to Log in to post a reply. Or register here, for free.