Burp Suite User Forum

Login to post

Error installing BurpSuite on Debian GNU/Linux 10 (buster)

Pseudo | Last updated: Apr 30, 2020 06:48PM UTC

I get the following error message when trying to run the Bash script installer. Unpacking JRE ... Starting Installer ... No protocol specified An error occurred: java.lang.NoClassDefFoundError: Could not initialize class java.awt.GraphicsEnvironment$LocalGE Error log: /tmp/install4jError14972146220755538279.log java.lang.NoClassDefFoundError: Could not initialize class java.awt.GraphicsEnvironment$LocalGE at java.desktop/java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(GraphicsEnvironment.java:129) at java.desktop/sun.awt.X11.XToolkit.<clinit>(XToolkit.java:232) at java.base/java.lang.Class.forName0(Native Method) at java.base/java.lang.Class.forName(Class.java:332) at java.desktop/java.awt.Toolkit$2.run(Toolkit.java:588) at java.desktop/java.awt.Toolkit$2.run(Toolkit.java:583) at java.base/java.security.AccessController.doPrivileged(AccessController.java:310) at java.desktop/java.awt.Toolkit.getDefaultToolkit(Toolkit.java:582) at java.desktop/javax.swing.ImageIcon.<init>(ImageIcon.java:198) at java.desktop/javax.swing.ImageIcon.<init>(ImageIcon.java:217) at com.install4j.runtime.installer.frontend.GUIHelper.loadIcon(GUIHelper.java:193) at com.install4j.runtime.installer.frontend.GUIHelper.<clinit>(GUIHelper.java:52) at com.install4j.runtime.installer.frontend.headless.AbstractHeadlessScreenExecutor.init(AbstractHeadlessScreenExecutor.java:73) at com.install4j.runtime.installer.frontend.headless.ConsoleScreenExecutor.<init>(ConsoleScreenExecutor.java:24) at com.install4j.runtime.installer.frontend.headless.InstallerConsoleScreenExecutor.<init>(InstallerConsoleScreenExecutor.java:6) at com.install4j.runtime.installer.Installer.getScreenExecutor(Installer.java:87) at com.install4j.runtime.installer.Installer.runInProcess(Installer.java:56) at com.install4j.runtime.installer.Installer.main(Installer.java:45) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.base/java.lang.reflect.Method.invoke(Method.java:567) at com.exe4j.runtime.LauncherEngine.launch(LauncherEngine.java:85) at com.install4j.runtime.launcher.UnixLauncher.start(UnixLauncher.java:66) at install4j.Installer3680162217.main(Unknown Source) FYI: Below is the output of java -version openjdk version "11.0.7" 2020-04-14 OpenJDK Runtime Environment (build 11.0.7+10-post-Debian-3deb10u1) OpenJDK 64-Bit Server VM (build 11.0.7+10-post-Debian-3deb10u1, mixed mode, sharing) Is there anything Im missing or missed downloading? Any help will be greatly appreciated.

Uthman, PortSwigger Agent | Last updated: May 01, 2020 07:34AM UTC

Can you share the full error log via email? Do you have issues launching burp from the standalone JAR file too?

Pseudo | Last updated: May 01, 2020 03:31PM UTC

Will do. I'll follow up on an email.

Pseudo | Last updated: May 01, 2020 03:39PM UTC

For reference, I just replied to an email with the log file to support@portswigger.net.

Uthman, PortSwigger Agent | Last updated: May 04, 2020 07:08AM UTC

Thanks! We will review it and get back to you.

Gabor | Last updated: Aug 26, 2020 04:38PM UTC

Hello everyone, I had exactly the same issue like Pseudo. I can share you what was my solution, but unfortunately I can't explain in detail why this happened, as I am pretty new to Linux.. So, if I did: your@name:~$ sudo ./burpsuite_community_linux_v2020_8_1.sh - I had the same error message. But if I did: your@name:~$ ./burpsuite_community_linux_v2020_8_1.sh Unpacking JRE ... Starting Installer ... Gtk-Message: 17:41:39.490: Failed to load module "canberra-gtk-module" So, I did: your@name:~$ sudo apt-get install libcanberra-gtk-module After that, I did again: your@name:~$ ./burpsuite_community_linux_v2020_8_1.sh The install started this time and just before the end I got a pop up error message what said either way I should started the install as sudo/root or after the install do:'sudo chown root:root /home/your_name/BurpSuiteCommunity/burpbrowser/84.0.4147.125/chrome-sandbox && sudo chmod u+s /home/your_name/BurpSuiteCommunity/burpbrowser/84.0.4147.125/chrome-sandbox'. I clicked continue, than finish. After that, I just did the chown as it was mentioned and everything is working fine. My Java: openjdk version "11.0.8" 2020-07-14 OpenJDK Runtime Environment (build 11.0.8+10-post-Debian-1deb10u1) OpenJDK 64-Bit Server VM (build 11.0.8+10-post-Debian-1deb10u1, mixed mode, sharing) On a Debian GNU/Linux 10 (buster). Hope it will help. All the best, Gabor

Key | Last updated: Dec 30, 2020 03:44PM UTC

I am having the same issue, should I write also to support or the solution is anywhere around?

Liam, PortSwigger Agent | Last updated: Dec 30, 2020 05:52PM UTC

Have you tried the solution above?

Key | Last updated: Jan 11, 2021 01:45PM UTC

I did! I tried it but no change.

Liam, PortSwigger Agent | Last updated: Jan 12, 2021 07:55AM UTC

Can you share the full error log via email? Do you have issues launching burp from the standalone JAR file too?

You need to Log in to post a reply. Or register here, for free.